Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    J D (jdancho)      Join Date: Apr 2009       03-24-2010, 1:06 PM Reply   
When I change my oil on my 2009 Supra with the 340 indmar engine I use the drain hose and it come out very slowly, and end up taking about two hours to fully drain the oil. I make sure I run the boat for about 5 minutes to heat of the oil so I'm not sure why it is doing that. My buddies Moomba with the same engine only take 5 minutes to drain all the oil out using the same method.

So I was wondering if anyone have any solution to the problem. Coming up is going to be the third time changing our oil and hopefully will not take as long.
Old    JUST-IN-TIME (justintime)      Join Date: Mar 2009       03-24-2010, 1:15 PM Reply   
sounds like a kink in the oil line

also remove oil cap and try that when draining
Old    Adam Curtis (acurtis_ttu)      Join Date: May 2004       03-24-2010, 1:24 PM Reply   
my 07 supra ( same motor) takes close to an hour to drain completely usign the method you described.
Old    Jman (jmanolinsky)      Join Date: Dec 2005       03-24-2010, 1:49 PM Reply   
IMO, if the engine is cold, all the oil is in the bottom of the pan, right where I want it. Running the engine might warm up the oil, but it also distributes it throughout the engine. I just find something else that needs to be done while the oil is draining. If you keep your boat somewhere that requires you to change your oil quickly, I guess other methods might be a better solution for you. Maybe an Oil Boy Pump is the answer.
Old    Derek (camassanger)      Join Date: Oct 2009       03-24-2010, 2:56 PM Reply   
I'd let the engine run longer if you want it to drain quicker. 5 minutes isnt really enough to get the oil hot, is it? How about draining after running it on the lake, when the whole system is hot and oil is at about max temp?
Old    Chris (rio_sanger)      Join Date: Apr 2007       03-24-2010, 3:54 PM Reply   
Quote:
Originally Posted by camassanger View Post
I'd let the engine run longer if you want it to drain quicker. 5 minutes isnt really enough to get the oil hot, is it? How about draining after running it on the lake, when the whole system is hot and oil is at about max temp?
I agree, 5 min. is hardly enough time. In fact, you'll never get your other fluids to operating temp on a fake a lake. I have the benefit of storing my boat 30 feet from the river, so I just change fluids after a good run when everything is warm. If you can't do that, you might use a suction pump on the end of the drain line. Also the suggestion on removing the filler cap is a good one to let air in.
Old    Matt Laird (Matt)      Join Date: Mar 2010       03-24-2010, 4:00 PM Reply   
I was reading this tread yesterday... For a few bucks it may be exactly what you need...




http://supraboats.com/bbs/showthread.php?t=5776
Old    Brad Webb (04outback)      Join Date: Jul 2007       03-24-2010, 6:37 PM Reply   
I use an electric pump and run the hose inside the drain hose on the engine... helps.. but has to be warm for pump..
ditto on the more than 5 minutes though..
Old    JUST-IN-TIME (justintime)      Join Date: Mar 2009       03-24-2010, 10:24 PM Reply   
i do not think that is oil rated pump

i would be wary of an explosion
Old    Tre (tre)      Join Date: Jul 2002       03-24-2010, 10:59 PM Reply   
There is no place for air to get in to replace the oil draining out so it is creating vaccum. If you pull the oil dipstick up an inch or so, this will allow air in and the oil drains in 5 min.

Also, make sure the boat engine is up to temp and then let it sit for 5 to 10 min to let to oil drain back into the pan before you unscrew the cap on the quick drain hose. Doing it this way has never taken me more then 5 min to drain the oil in any Supra I've owned.
Old    Travis (fman)      Join Date: Nov 2008       03-25-2010, 12:09 AM Reply   
Try using a good oil pump, the TEMPO works great, and can also be used on the transmission fluid as well. This pump is super easy to hook up and will not require you to run the drain line out the transom hole which is a PIA. This pump will drain your pan in about 1-2 minutes.

Heres another link that will help you out:

http://www.supraboats.com/bbs/showth...0950#post30950
Attached Images
  

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 8:05 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us