Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME

Statistics
Account Type:WakeWorld Members
Network:Default
Profile Views:27828 profile views
Friends:49 friends
Updated:1 year(s) ago
Signup Date:November 9, 2009
Posts:
9286
Points:
Calendar
Groups (1)
Malibu Riders
My Profile
My Friends
Comments
Events
Polls
 
About Me
Username:
wakeworld
First Name:
David
Last Name:
Williams
Gender:
Occupation:
Wake Industry Affiliation:
Employer:
City:
State:
Country:
Home Ride Spot:
Website:
Facebook:
Twitter:
Other Social Network:
Personal Quote:
It's a simple question. If the moon were made of spare ribs, would you eat it??
My Gear
Board(s):
CWB Vibe 142
Bindings:
CWB JT's
My Boat
Boat Year:
2014
Boat Make:
Malibu
Boat Model:
Wakesetter 23 LSV
Trailer:
Boatmate
Engine:
Monsoon 450HP LS3 6.2L
Prop:
14.5x14.25
Ballast Setup:
Stock ballast + 1500 lbs.in Pop Products and Lead Wake bags +1500 lbs in Plug n' Play rear sacks
Stereo Setup:
Stock setup with four Wet Sounds 696 on the tower and a Wet Sounds WS-420SQ EQ/PA system to give a shout out to my riders! We've also added a Wet Sounds Bluetooth controller.
Options / Accessories:
So far we've added the Plug n' Play system from WakeMakers and a WS-420SQ and Bluetooth controller from Wet Sounds.
Tow Vehicle:
2001 Yukon XL
Recent Activity
8 day(s) ago
wakeworld made a post in this thread: Hurricane Dolores - 7/18/15
Click on the "Go Advanced" button at the bottom. Then click on the paper clip attachment button to upload photos.
3 week(s) ago
wakeworld made a post in this thread: Migration Pass
I drove down with my boat a couple of weeks ago. Although they held us there for about 15-20 looking through the boat and playing with paperwork, I got through ok and didn't have to pay any fee. I did fill out some paperwork and they asked how lon...
3 week(s) ago
wakeworld made a new Thread
3 week(s) ago
wakeworld made a post in this thread: Website seems to be having glitches
Try going to the front page and logging out with the Log Out button. Then restart all browsers and log in again from the front page. Let me know if that works for you.
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME

 

© 2012 eWake, Inc.
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us