Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME

Statistics
Account Type:WakeWorld Members
Network:Default
Profile Views:3868 profile views
Friends:0 friends
Updated:3 week(s) ago
Signup Date:February 11, 2012
Posts:
361
Points:
Calendar
My Profile
 
About Me
Username:
Midnightv10
First Name:
Russ
Last Name:
Constable
Gender:
Birthday:
Occupation:
Employer:
City:
State:
Country:
Home Ride Spot:
My Gear
Board(s):
Ronix / Slingshot / Liquid Force / Soulcraft
My Boat
Boat Year:
2012
Boat Make:
MB Sports
Boat Model:
F-23 Tomcat
Trailer:
CTW
Engine:
PCM 409
Prop:
Acme 2079
Ballast Setup:
2400# Gate Controlled Internal
3000# Bags and Pumps
Wake Plate
Home Built Surfgate
Stereo Setup:
Clarion Head Unit
Arc Audio ALD
WS 420 SQ
1 - WS SD2 - Sub
1 - WS SD4 - Tower
1 - WS SD6 - In Boats
2 - WS Rev 410's
4 - WS XS-808's
6 - WS XS-650's
1 - WS-XXXv2 Sub
Options / Accessories:
DEKA 6-Volt AGM Batteries - 4ea - Stereo
DEKA 12 Volt AGM Batteries - 2ea - Starting
Blue Seas Add a Battery
ProMariner On Board Charger
Samson Typhoon Wakeboard Racks
Samson Cannon Surf Racks
PTM Edge MIrror
Tow Vehicle:
2008 GMC Denali
Recent Activity
1 day(s) ago
Midnightv10 made a post in this thread: Surf Addicts Wakesurf Board Reviews
Great write up on the LF Desi.. Should be getting my new Soulcraft any day now.. next time we go out you can demo that
1 day(s) ago
Midnightv10 made a post in this thread: Installing WS420 tonight any advice for stating settings?
I had a buddy with the exact same issue.. just kept popping fuses.. Bad EQ, dealership swapped it out for a new one
1 day(s) ago
Midnightv10 made a post in this thread: SYS2 to SD2 problem
Not necessarily but that could be the issue. so if I am understanding you right, your remote turn on lead comes from the head unit to the SYN 6 and then is daisy chained over to the other amp? if so, try disconnecting the turn on lead from the 6 a...
1 day(s) ago
Midnightv10 made a post in this thread: SYS2 to SD2 problem
My only other suggestion (other than the amp may be bad) is to check your remote turn on lead. A few years back I had 3 Fosgate amps with the remote turn on leads wired straight to the head unit. Wouldn't turn the amps on. I then wired them throug...
1 day(s) ago
Midnightv10 made a post in this thread: SYS2 to SD2 problem
Did you check the fuses in the amp?
9 day(s) ago
Midnightv10 made a post in this thread: Wiring 4 Rev10's with 1 KS600.2
If you only have 2 pairs of wires coming down to the amps the speakers may already be wired parallel inside the tower. If that is the case, just hook each wire pair to each channel of the amp.
9 day(s) ago
Midnightv10 made a post in this thread: Wiring 4 Rev10's with 1 KS600.2
You should have 4 pair of speaker wires running from the tower to the amps. that is 4 positives and 4 negatives. wire the positives together from say the 2 port speakers to the positive output of the left channel of the amp. wire the 2 negatives ...
9 day(s) ago
Midnightv10 made a post in this thread: Wiring 4 Rev10's with 1 KS600.2
wire them in parallel. if your pre wired to the amp just run a pair of positives and negatives to each of the 2 amp channels.
3 week(s) ago
Midnightv10 made a post in this thread: Trayson's DIY "Supra Surf System" (SSS) modeled after the NSS
I hate being cold
3 week(s) ago
Russ Constable updated their profile.
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME

 

© 2012 eWake, Inc.
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us