Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Nathan Gort (TNwakeboarder86)      Join Date: Sep 2016       07-17-2017, 5:54 AM Reply   
I tried this on Malibu crew but I figured I should here as well. My perfect pass wasn't catching well ok not at all but the end. Now the throttle needs to be pushed 90 degrees before it will go. I have 04 vlx Malibu. I have read a lot of stuff, people say tighten the throttle cable, others are saying with perfect pass, the older version, there is a knob to tighten. Another person is saying to replace the springs. These are all really old post, has anyone else had this issue and what was the problem and fix? If you have pics great, i am going to try and work on it this week. I read perfect pass trouble shooting, it sounds like it could be that.
Old    D (infinitysurf)      Join Date: Apr 2017       07-17-2017, 7:16 PM Reply   
You should post on TheMalibuCrew Forum. Likely to get the best answer
Old     (ashjbrown)      Join Date: Jul 2012       07-17-2017, 7:17 PM Reply   
this happened to me and it was the servo motor
Old    Nathan Gort (TNwakeboarder86)      Join Date: Sep 2016       07-18-2017, 5:17 AM Reply   
Hey I posted it on Malibu crew, but they are very slow to respond. I went in yesterday and worked on it, come to find out it was the perfect pass knob. I had to tighten it clockwise and it pulled it tight. No idea that was there. Learned something knew, now if I can only find how to make the throttle box strong, since the screws seem way to loose.
Old    Jack Henry (racer808)      Join Date: Jan 2013       07-18-2017, 5:48 AM Reply   
Go to your perfect pass motor. There is a winding that you can tighten with your hands. Can't remember if its' where the throttle cable attaches, or if it's a little string, either way, you'll see it, wind it back up, there is probably too much slack. Happens frequently actually, shocked the Crew didn't give you that answer???? I am struggling with boat forums these days, anyone with a newer boat has the same reply everytime. Me: my boat is doing such & such, anyone have a fix. Forum user: "oh, my boat was doing the same thing". Me: What was the solution? Forum user: "oh I don't know, I took it to the dealer".

Edit: Just realized you found the issue yourself, didn't read last post.
Old    Nathan Gort (TNwakeboarder86)      Join Date: Sep 2016       07-18-2017, 8:16 AM Reply   
jack I agree with you. I bought a heck of a deal on a older boat, couldn't pass it up. But im coming across more and more things. The guys I have that work on the side fiberglass and mechanic been so busy since they do a lot of work for the boat companies. Thankfully this was an easy fix.

Still on my to do list is:
My fill on one ballast isn't working, but it empties fine,
My throttle is so lose bc the screws don't hold in to well so it can come out. I have no idea how to take the side panel off so I can put washers and a nut back there to hold it in.
3rd, for the life of me, the wet sound stereo system, its loud as crap but no matter what the other speakers have static if I play it through the tower only, then if I play it through everything, its not as clear. I think there is a wire somewhere.
4th, I cant get my cooler to drain, I been sticking a hanger in the hole nothing yet, next is high power air.

I do wish more people responded.
Old    Jack Henry (racer808)      Join Date: Jan 2013       07-18-2017, 11:34 AM Reply   
Quote:
Originally Posted by TNwakeboarder86 View Post
jack I agree with you. I bought a heck of a deal on a older boat, couldn't pass it up. But im coming across more and more things. The guys I have that work on the side fiberglass and mechanic been so busy since they do a lot of work for the boat companies. Thankfully this was an easy fix.

Still on my to do list is:
My fill on one ballast isn't working, but it empties fine, FILL PUMP IS PROBABLY BAD. I'M GUESSING YOU HAVE AERATOR PUMPS? BY THE V DRIVE YOU SHOULD SEE YOUR FILL PUMPS MOUNTED THROUGH THE HULL. YOU CAN BUY THEM ON AMAZON FOR 20 OR 30 BUCKS. IF YOU DON'T HAVE SHUT OFF VALVES INSTALLED WITH THOSE PUMPS I STRONGLY SUGGEST ORDERING SOME OF THOSE FOR SAFETY. YOU CAN GET BY WITH THE HOME DEPOT VALVES BUT THEY WILL CORRODE VERY QUICKLY, WAKE MAKERS SELL THE ONES THAT WON'T CORRODE, NOT SURE WHERE ELSE YOU CAN GET THOSE TYPES?

My throttle is so lose bc the screws don't hold in to well so it can come out. I have no idea how to take the side panel off so I can put washers and a nut back there to hold it in. YOU GOTTA REACH BEHIND THE PANEL FROM BOTH SIDES & TAKE OFF A FEW NUTS. THE STUDS THE NUTS COME OFF ARE UP HIGH WHERE THE PANEL MEETS THE HULL, I RECOMMEND THOSE RATCHET TYPE BOX END WRENCHES FOR THIS. MY SIDE PANEL WAS CRACKED & FLOPPY. I USED PLASTICS TO RECREATE SUPPORT FOR THE THROTTLE AS WELL AS ALL THE CRACKED PLASTICS BEHIND IT & TONS OF TWO PART EPOXY & IT WORKED SURPRISINGLY WELL.

3rd, for the life of me, the wet sound stereo system, its loud as crap but no matter what the other speakers have static if I play it through the tower only, then if I play it through everything, its not as clear. I think there is a wire somewhere. PROBABLY NEED TO REROUTE GROUNDS DIRECT TO BATTERY FROM STEREO & AMPS. YOU CAN ALSO BUY THOSE NOISE ELIMINATORS YOU RUN YOUR RCA'S THROUGH. ALTHOUGH AUDIO HEADS WILL BEAT YOU FOR DOING SO BUT IT'S A QUICK $20 FIX FROM CAR TOYS. YOU CAN ALSO REACH OUT TO DAVE ANALOG ON HERE OR MALIBU CREW, HE TYPICALLY SPEAKS OVER EVERY ONES HEAD BUT HE WILL DUMB IT DOWN IF NEED BE.

4th, I cant get my cooler to drain, I been sticking a hanger in the hole nothing yet, next is high power air. I HAD THE SAME ISSUE, THERE WAS A HOLE BUT THERE WAS ALSO A SMALL PIECE OF PIPE THAT WAS SUPPOSED TO BE THERE THAT SOMEHOW GOT DISLODGED. I DIDN'T LIKE THE COOLER & WE HAD A BAG TYPE COOLER THAT FIT THERE PERFECT & WORKED BETTER L SO I NEVER CORRECTED THE ISSUE.

I do wish more people responded. THEY'RE ALL AT THEIR DEALERS HAVE THEIR WARRANTY PROBLEMS WORKED OUT .
See above in caps my friend.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 8:27 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2016 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us