Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > Video and Photography

Share 
Reply
 
Thread Tools Display Modes
Old     (One2Many)      Join Date: Mar 2013       07-06-2015, 3:17 AM Reply   
So I have a set of rev 10 tower speakers. Had them for 2 years now. I blew both speakers last year and I'll admit that was probably my fault, but I had both speakers repaired and I have them turned down to make sure I wouldn't damage them again and on my second day of boating I am getting no sound at all out of them just a loud static. My loud mic works fine threw them which leads me to think that maybe some lose connection or something is occurring? I'm not very good when it comes to electronics. So what do you guys think? Lose connection or are they blown again? Thanks.
Old     (corerider)      Join Date: May 2008       07-06-2015, 7:53 AM Reply   
So if your "loud mic" works (I assume you have a WS420) that tells me the link between it, the amp, and amp-speakers is fine. If the speakers or amp were damaged to the point of not playing music I wouldn't think the mic would work either. Might want to try looking at the path the music takes to your EQ. You may have a bad cable, HU, mobile device output, or perhaps the WS420 input. I'm not sure how the circuity works on them, but I would guess the mic is separate from the main and aux inputs. This does not sound like a speaker issue!
Old     (zimme)      Join Date: Feb 2013       07-15-2015, 2:14 PM Reply   
Do you have the correct input selected on your 420sq? Main vs Aux?
Old     (Jmorlan)      Join Date: May 2013       07-15-2015, 3:07 PM Reply   
Quick question here, sorry to interrupt, but does anyone with a 420 and the ws bluetooth, when you use the bt it's is louder than just the aux cable
Old     (moto817)      Join Date: Jan 2011       07-15-2015, 10:57 PM Reply   
Aux cable puts out less volts than the WS BT so yes the BT will be louder

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 3:39 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2016 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us