Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Nick Heckerson (kstateskier)      Join Date: May 2002       05-13-2014, 10:46 AM Reply   
Anyone have any issues with the middle screen going completely black with Sync? My wife called this morning and said that her entire middle screen wouldn't come on today on the way to work and that none of the controls work. It's a '13 Explorer. We had a ton of issues early on, but after the last re-flash had never had an issue. Usually re-starting does the trick, but not this time. Saw some similar issues on some Ford forums and they recommended pulling the battery cable to reset. I'm going to do this when she gets home, but wondered if anyone on her might have already had the issue.

I am really starting to wish I had done some more research on the Sync system before buying this. After 2 flawless F-150s I jumped in headfirst without doing a lot of research. We have had a ton of issues with this car in the first 50k.
Old    John (blackstang)      Join Date: Dec 2013       05-13-2014, 12:33 PM Reply   
Is it the MyTouch system or regular SYNC? I am the SYNC specialist at our Ford Store and can hopefully walk you through any issues?
Old    Nick Heckerson (kstateskier)      Join Date: May 2002       05-14-2014, 11:30 PM Reply   
John, appreciate it. It actually started working again. Not sure the difference, it's a '13 Limited. Full touch screen.
Old    John (blackstang)      Join Date: Dec 2013       05-15-2014, 8:43 AM Reply   
It would be the MyTouch system then. If you want a PM me your VIN I can check to see if it has any updates? Most common problems with these are easily fixed with a update done through the USB drive.
Old    Baitkiller (baitkiller)      Join Date: Jan 2010       05-15-2014, 1:31 PM Reply   
John, I too am in a world of hurt with Sync.
My dear, beautiful, intelligent wife left the sun roof open in her 2009 Flex.....>.>>>> It rained.<<<<< Me? I'm the idiot who opted for the $1,000 deductible on the insurance. Wont make that mistake again.
After much drying and now 1 year of time the best I can get is the whole left side of the controls are inop, rear air inop, all sync functions inop but the stereo plays (have to use the steering wheel controls) and the fwd AC works,,,... sort of.
Rear AV system,works. We do not have navigation.system installed, only AV.
Pretty sure its gonna be a mass component swap thing and my local Ford dealer is such a prick I drove four hours away to buy this one.

You wouldn't happen to have a few spare circuit boards under your bench collecting dust would you?
Old    Trapper (canucked)      Join Date: Jun 2007       05-15-2014, 1:52 PM Reply   
Speaking of Sync, I wish you could turn off the screen at night, i know you can dim it but its like 20 buttons.

I used to have a Saab 9-3, it had a "stealth mode" where you could turn off everything except your current speed with one button, it was so awesome at night. On my Ford (fusion) I feel like I need a "too much information" button.
Old    John (blackstang)      Join Date: Dec 2013       05-15-2014, 7:41 PM Reply   
Baitkiller, I do not have any parts for that style of vehicle. So you must have just the regular style radio w/o the large screen if you don't have Nav right? That being said I would just try to find one from a salvage yard.. You may have to do a programmable module installation afterwards, but it's not that big of a deal. Unfortunately it would require a visit to a dealer though.
Old    Baitkiller (baitkiller)      Join Date: Jan 2010       05-16-2014, 5:02 AM Reply   
I think I found one for $529 at a wrecker. So everything is in the radio then? No obscure modules stashed in crazy places i should R&R while I'm in there?
Old    John (blackstang)      Join Date: Dec 2013       05-16-2014, 9:01 AM Reply   
Well w/o being there to test it, I'm leaning more towards it having a problem with the (FDIM) front interface display module. The actual radio sits in behind this and would be less likely to have been damaged by the rain. The (ACM) audio control module (fancy word for radio) would also need to be reconfigured after installation. The FDIM is the control panel that has all your buttons and switches for the radio and climate control. I see it being the only component that would be damaged by water that controls all of the items you listed and it will not need to be programmed after install. Hopefully this helps you?
Old    Baitkiller (baitkiller)      Join Date: Jan 2010       05-16-2014, 9:42 AM Reply   
Thank you thank you thank you..
Old    John (blackstang)      Join Date: Dec 2013       05-16-2014, 10:31 AM Reply   
I just had my parts guy check on a new one for you. It is aprx $278.00 and the exchange company said they must not have any noticeable water or physical damage for a core credit. Kind of odd, they asked if it had water damage from leaving the sunroof open! Also, went on to say they are back ordered for minimum of 2 weeks.
Old    Baitkiller (baitkiller)      Join Date: Jan 2010       05-16-2014, 1:40 PM Reply   
Nick, sorry for the hijack
John, you are the best thank you. I tried to PM you but the function isnt working.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 9:19 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us