Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Non-Wakeboarding Discussion

Share 
Reply
 
Thread Tools Display Modes
Old    Danny Simon (wakerider42)      Join Date: May 2002       09-08-2012, 8:29 AM Reply   
Hey guys,

Man I haven't been on here in forever! Living down in Costa Rica still, haven't been out to Sander's place yet, but I think we're going to at some point. Miss my loaded down Malibu VLX rocking the backwater at Canyon Lake!!

Anyway, my 2009 Hyundai Tucson 2.0L gas car is sucking crap on power. I posted a detailed thread on www.hyundai-forums.com, but no replies. This is not really a Hyundai-specific problem, so I was wondering if you guys have any good experience with a general automotive forum where I could get some help. I might get better activity there.

Hope all is good in the WW community.

Thanks a lot.

Later,
Danny Simon
Old    Akadirtbikingdad (wakeboardingdad)      Join Date: Aug 2008       09-09-2012, 8:11 AM Reply   
Replace the fuel filter...

Sorry, that it always the first thing to check on a FI car. I always look at vehicle specific forums, but have also found help on about.com and other how-to websites which come whenever I internet search.

Good luck.
Old    Danny Simon (wakerider42)      Join Date: May 2002       09-09-2012, 8:19 AM Reply   
Yeah, air and fuel filters were my number one suspicions, especially considering the dirty fuel down here. The air filter was fairly new but I swapped it anyway with no change. Then I changed the fuel filter Friday. That was fun...of course the fuel filter is part of an over-engineering assembly housing the pump, level sensor, etc. and is all submersed inside the tank, which you can't access without removing the entire back seat. Then you have to transfer like 15 things including the pump itself from the old assembly to the new! Good thing I am pretty decent with the ol' wrench set from my moto days.

Here is the thread I posted if anybody is bored on a Sunday and wants to help.
http://www.hyundai-forums.com/150-pe...osta-rica.html

In general, I find those About.com websites not very good for detailed help...I will do some searching though and give it a shot.

Thanks!
- Danny
Old    Johnny Zero (dirtrider)      Join Date: Sep 2008       09-09-2012, 10:01 AM Reply   
Could be a lot of things. I would look at cleaning / replacing MAF sensor next.
If you clean it make sure to use the stuff made for cleaning MAF sensors as they are very sensitive.
You might also check the catalytic converter to make sure it isn't starting to clog up. Since the
fuel filter seemed dirty you might try to run a couple of bottles of injector cleaner through the system.
Since it looks like you are going to be shade treeing the repairs on this vehicle I would suggest getting a cheap scan tool to pull codes etc. Good luck!
Old    Danny Simon (wakerider42)      Join Date: May 2002       09-09-2012, 10:09 AM Reply   
Thanks Johnny, good suggestions. I should have mentioned, there are no codes being thrown. Re: the catalytic, if it were plugging, would it be giving off the "rotten eggs" smell, or not necessarily? Mine is not giving the rotten eggs smell, so the catalyst itself must be good. But perhaps it is physically plugging.
Old    Johnny Zero (dirtrider)      Join Date: Sep 2008       09-09-2012, 10:16 AM Reply   
Sometimes rather than clogging the guts of the converter will break and start to turn sideways, causing a clog but no smell. Best way to check for this is to hit it with a mallet of block of wood and see if it makes a rattle noise.
Old    Danny Simon (wakerider42)      Join Date: May 2002       09-09-2012, 10:35 AM Reply   
Gotcha, that is an excellent possibility. Lots of humidity and crappy roads down here could easily cause this. I will put that on the top of the list of things to check once I finished with the lame part of my day (working remotely from home, BLAH!)
Old    Danny Simon (wakerider42)      Join Date: May 2002       09-09-2012, 5:08 PM Reply   
Ok I checked the catalytic converter and other exhaust components, no obvious signs of internal breakage when hitting with a mallet.

I also inspected the plug wires which all looked fine. Was gonna try to measure the resistance to OEM spec, but my multimeter isn't working.

I pulled a couple spark plugs, which looked normal. Kind of a nice medium-brown color with no deposits or anything that jumped out at me as suspect. I checked the plug gap while I was there...right at nominal of OEM spec.

I added a bottle of fuel injector cleaner to a fresh tank today, we will see what happens.

I'm going to try to duck out of work tomorrow with a local co-worker and see if I can have the fuel pressure tested to rule out fuel supply or not. My gut is still telling me it's starving for fuel based on how it behaves when trying to accelerate up mild inclines. That or maybe an ignition coil or something that impacts the overall system as a whole. And being that there aren't any check engine lights, it seems that the computer system/sensors as a whole are happy.

Thanks for helping.
-Danny
Old    Danny Simon (wakerider42)      Join Date: May 2002       09-09-2012, 5:32 PM Reply   
Here is a picture of one of the spark plugs.
Attached Images
 
Old    Akadirtbikingdad (wakeboardingdad)      Join Date: Aug 2008       09-09-2012, 7:11 PM Reply   
I'm not a fan if injector cleaner. Just me though. We ran some through a Camaro - high miles - and they all started leaking. Yours will probably be different though. To clean the MAF, you use some electronic component cleaner. Something that evaps really quickly and leaves no residue. I get mine from Home Depot - do they have Hut Depot in Costa Rica?

Nice floor in your "hut" by the way.

BTW, regarding your plug. The greyish tint does mean it could be a bit lean. Perhaps the grade you're talking about and being lean going up it. A nice reddish tint is perfect, but a friend of mine said with the fuel these days, that doesn't happen. I'm not a 100% believer on that though.

Last edited by wakeboardingdad; 09-09-2012 at 7:17 PM.
Old    Danny Simon (wakerider42)      Join Date: May 2002       09-12-2012, 8:35 PM Reply   
Took it in Monday. Ran a full scanner test which confirmed no codes and all sensors check out fine. Ran a vacuum check on the intake which held good vacuum (~17inHG, it was green on his gauge...I guess pretty standard) apparently indicating that the exhaust system is not plugged. Checked pulse timing of the injectors which checked out fine. Checked ignition system including coils, wires, etc. all check out fine. Checked fuel supply pressure.

Took the guy on a long test drive to show all the symptoms. Actually sort of settled on that it might just be a slipping auto trans (torque converter) or maybe a faulty signal for the trans to lock-up. Left it that night and they had their transmission guy look at it on Tuesday. Transmission guy says the trans checks out fine.

So they ran some more testing, including a compression test and leak-down test. Turns out cylinders #1 and #3 are low on compression. Root cause is a leaky head gasket. We've never overheated it to cause head warpage, but who knows in its prior life. So they are pulling the head off and checking it out further. Crossing my fingers that there are no other internal issues, and they can just re-surface and put a new gasket on and call it a day. We will see. I'm for sure into it for at least $1,000 now. Go Kia rental car haha!!!

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 2:01 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us