Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Brent Damlow (dzldoctor)      Join Date: Jul 2010       07-15-2012, 11:20 AM Reply   
Looking for a scan tool or something to diagnose my 1996 with mercruiser 350 MPI. The boat had always worked great till camping this last week. Started to idle high and run rich. Would also backfire at wot if you cut back some it would run great. Still had the goofy rich high idle. You can smell rich, and it idlse about 1000 rpm. Intermittently it will work properly. Tried to unplug the sensors (iac,tps coolant,map) with no change in operation. I would not mind spending a few hundo on a scan tool to communicate with the machine. Got a basic tune up last fall before I put away for the season. Oil change,fuel filter and spark plugs. Thanks in advance.
Old    Baitkiller (baitkiller)      Join Date: Jan 2010       07-15-2012, 2:54 PM Reply   
Sounds like a vacuum leak. Use your ears and eyes first. maybe something simple.
Old    Greg McNeill (greg2)      Join Date: May 2002       07-15-2012, 4:01 PM Reply   
A bad fuel pressure regulator can also make an engine run rich.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 1:56 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us