Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    CORY MITCHELL (stang_killa_ss)      Join Date: Jan 2010       06-30-2012, 11:55 AM Reply   
pump finally gave up the ghost...
jabsco 18220-7127 from '11 moomba LSV
i called the stealership and they do have one for $290 + tax + the 3 hours on the road to get it.(they also confermed the part number)

well i google that number and google nor yahoo could find ONE SINGLE hit on that number

but there are a million hits for the 18220-1127 which wakemakers sells as well. $209
http://www.wakemakers.com/jabsco-bal...oard-pump.html

it looks 99% identical but obviously the part number is wrong. i wonder what the difference is? and why cant google find a single hit on my part number?

i wonder if the difference is the plug thats on mine for moomba? (1127 has no plug) or possibly the impeller type although both come with the nice green impellers.

any one have any knowledge with this?
Old    TigeMike (chpthril)      Join Date: Oct 2007       06-30-2012, 12:13 PM Reply   
Just curious, does your 2011 not have warranty that covers this? I also find it odd that a year old ballast pump motor would fail. Was it mounted with motor down/head up?

Yes, the 1811-1127 should work. Is yours used as a reversible, or does it just fill the sacs? if you only need one to pump one way, Jabsco makes a 6+ GPH pump that runs about $150.00.
Old    CORY MITCHELL (stang_killa_ss)      Join Date: Jan 2010       06-30-2012, 12:17 PM Reply   
it did have warantee. in february. lol the only thing that failed on my boat during the 1 year warantee was a $3 stereo cable haha.
yeah i could get it to come on sorta by manually hooking up 12v directly to the wires, but the shaft waddled like crazy, and it grunted and growled terribly, and sound was wavy, ie rpms changeing alot. then it would just lock up again and short out when you would add 12v. now its locked up good. i cant even spin the shaft with pliers anymore.

yes it was mounted vertically. impeller on top. yes mine is reversable.

i would just really like to find out more about the 7127. its just crazy that theres not one single trace of this pump on the internet.....
Old    TigeMike (chpthril)      Join Date: Oct 2007       06-30-2012, 12:22 PM Reply   
Id bet if you pull it apart, you will find that water seeped into the motor and killed the bearing. Get the 1127 and mount it motor up.
Old    CORY MITCHELL (stang_killa_ss)      Join Date: Jan 2010       06-30-2012, 12:33 PM Reply   
yeah i already dismantled it and came to the same conclusion.
thanks for the orientation idea. thats a good point.

just wish i could find some kind of actual info on my 7127
Old    TigeMike (chpthril)      Join Date: Oct 2007       06-30-2012, 12:53 PM Reply   
Call Jabsco on Monday and ask them. They have a east coast office and a west coast office. Im sure they can tell you exactly what the diff is.

www.xylemflowcontrol.com is who the Jabsco name is under.
Old    Dax Jolly (volzalum)      Join Date: May 2009       07-01-2012, 7:42 AM Reply   
I talked to jabsco a few years ago when I was adding pumps to my system and they told me the ballast puppies were all the same with different numbers related to whether they were providing to retail or boat manufacturers. Most likely the the one in your boat was just branded (numbered) for your boat manufacturer.
Old    CORY MITCHELL (stang_killa_ss)      Join Date: Jan 2010       07-01-2012, 7:44 AM Reply   
that was my guess too. thanks for confermation. explains why google cant find a single thing on my part #
Old    Spencer (spencerwm)      Join Date: Feb 2009       07-01-2012, 9:01 PM Reply   
Quote:
Originally Posted by stang_killa_ss View Post
that was my guess too. thanks for confirmation. explains why google cant find a single thing on my part #
That is correct. Same pump with an OEM part number. To my knowledge the only Manufacturer that does run a little different pump is Correct Craft. They run the Commercial Water Puppy. Basically the same thing as the Jabsco Ballast Puppy.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:35 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us