Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Eubanks (eubanks01)      Join Date: Jun 2001       04-30-2012, 9:18 AM Reply   
A couple of my automated pumps keep tripping the circuit breaker when I turn them on. It seems to be just two of the four switches that do this and will shut themselves off a couple of seconds after I turn them on every time. These are replacement pumps that had to be wired into the factory system a couple of seasons ago and used to work fine.

Any thoughts about what it might be?
Old    Bill K (bill_airjunky)      Join Date: Apr 2002       04-30-2012, 9:30 AM Reply   
You should verify the impeller inside the pump is spinning freely. If not, it'll draw too many amps to spin & pop the circuit breaker.
Old    Eubanks (eubanks01)      Join Date: Jun 2001       04-30-2012, 11:21 AM Reply   
Thanks Bill. Can you take apart those Rule pumps?
Old    C.I.E. J-Rod (jarrod)      Join Date: May 2003       04-30-2012, 3:14 PM Reply   
I had the same problem after a couple year of use, and after storing the boat for long periods of time. We started flipping the switches back and forth from empty to fill to empty and back to fill before committing to one position, and the problem went away. I hope that made sense.
Old    Bill K (bill_airjunky)      Join Date: Apr 2002       04-30-2012, 3:39 PM Reply   
The pumps in my Malibu are Piranha 800s. There is a single screw on the top & then the top cap comes off with a twist. The impeller is underneath. I just replaced the drain pump in my mid-ship tank this winter. When I tried to spin the impeller it was frozen solid. I did get it to spin but had to twist pretty hard, which would have obviously taken waaaay too many amps.

I found them on Ebay for about $50 shipped.
Old    Spencer (spencerwm)      Join Date: Feb 2009       05-01-2012, 9:22 AM Reply   
The pump should come apart easily you can get them cleaned up. If it is gummed up and won't turn it might be time to buy a new one and save yourself the headache. They are only $50.

2003-2011 Malibu Shurflo Piranha Ballast Pump Video

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 9:35 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us