Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Travis Zajic (travisz)      Join Date: Jun 2008       04-05-2011, 9:02 AM Reply   
I have 2 amps mounted in my enclosed compartment in my Malibu.... They over heat! im not happy... I want to add some fans... what do you guys suggest and how did you mount them. I appreciate all your input. Thank you.

T
Old    Dave Kiehl (dave27)      Join Date: May 2005       04-05-2011, 9:07 AM Reply   
Change out the amps to the new digital type? Just a thougth and an expensive one.
Old    Harold Hemming (h20king)      Join Date: Dec 2009       04-05-2011, 9:07 AM Reply   
Do you have spacer blocks mounted between the amps and mounting surface so air is able to completely circulate around them ??
Old    Shawndoggy (shawndoggy)      Join Date: Nov 2009       04-05-2011, 9:34 AM Reply   
fans are unlikely to solve your problem, methinks. What's your battery situation? When are the amps overheating (while boat is running or while parked for a while)?
Old    Travis Zajic (travisz)      Join Date: Jun 2008       04-05-2011, 9:45 AM Reply   
I do not have spacers but I will try that for sure.
I have dual deep cycle batteries, and the amps over heat while the boat is running and parked in a cove. They do over heat less when the hatch of the compartment is open. They are mounted in the passenger side rear facing compartment in a wakesetter.
Old    Razzman (razzman)      Join Date: Dec 2006       04-05-2011, 11:01 AM Reply   
Just curious, what brand and model are the amps? What gauge wire is supplying the power to them? How do you have the gains set? What's your speaker/sub setup? You supplying power to anything else off of those dual batts? There's a lot of reasons they can overheat and it's not just the enclosed space that can do it, in fact in my experience it's typically not the case.
Old    Travis Zajic (travisz)      Join Date: Jun 2008       04-05-2011, 11:44 AM Reply   
Razz.. I wil have to get back to you on all that... im not really sure...
Old    Earmark Marine (david_e_m)      Join Date: Jul 2008       04-05-2011, 6:40 PM Reply   
Travis,
There are so many contributions to amplifiers going into thermal protection...too low of an impedance load for your particular amplifiers, speakers with partial VC damage, tuning as in crossover selection or misuse of equalization plus low voltage complicates thermal issues.
If your amplifiers are going into protection so easily as you've described, I think you need to investigate the core causes before using a bandage like a fan. A fan is a good solution when you're having occasional problems in July and August.

David
Earmark Marine
Old    James (Silverbullet555)      Join Date: May 2010       04-05-2011, 8:52 PM Reply   
Not saying it is the right solve, but when I did my amp racks I put in 4 cross flow fans. All the amps sit on risers so air can flow across all sides.


Closer pic.


The cover has brushed aluminum grills with a acryllic cover over them on standoffs. I did that so I didn't have to worry about it as I put stuff in that locker and I wanted a constant flow of air.

I wired them through a relay that activates with the remote turn on from the deck and I also wired them through a switch in the stereo panel.I also installed temp sensors on each amp so I can watch their temp if I am so inclined.



To further complicate the process I wired their power line through a thermal switch so that I can set the temp they come on at if I ever feel I need to.

Do I need them? Probably not. But, I did not want to find out later that I should have had them as I plan to only install this amp rack once.

Will it fix your issue? Don't know as it depends on the cause of the issue.

Just thought I would show what I did. I'm not an expert, just someone that does things they way I want to for my peace of mind.

Last edited by Silverbullet555; 04-05-2011 at 8:55 PM. Reason: Forgot one pic.
Old    Benjamin (bendow)      Join Date: Sep 2005       04-06-2011, 5:04 AM Reply   
Well that's just gorgeous! Well done! How much did that acrylic set you back James? What did you cut it with?

Is a relay necessary for the fans? Could you just wire them through a toggle switch?

I think fans are good to have if your amps overheat or not.
Old    James (Silverbullet555)      Join Date: May 2010       04-06-2011, 7:50 AM Reply   
I spent a fair amount on acryllic especially when I broke a large sheet. Probably around $150-200 for for the total project.

The reason why I went through a relay is all power that is tied to the remote turn on from the stereo is through 1 relay. 3 amps, 5 led strips, 2 gauges, 1 equalizer, 4 fans, etc. All of that is going through the relat so there is no load on the remote turn on from the stereo.

I cut the acryllic using a variety of tools. Some was scored and broken after scoring half way through. I used a jig saw for a little (a PITA). Finally I finished all edges with a router to clean them up.
Old    Travis Zajic (travisz)      Join Date: Jun 2008       04-06-2011, 8:01 AM Reply   
Wow guys thank you for all your input, David, I have gone to the extent of switching out amps from my truck to the boat, and still over heats. The part that really confuses me, is that the amp is soley powering 4 polk MM tower speakers and thats it... the other amp powering the sub and the other 4 polks never over heats. But no matter what amp I put for the tower speakers, it over heats, some just take longer than others. And yes it does over heat quicker in warmer weather.
Old    Travis Zajic (travisz)      Join Date: Jun 2008       04-06-2011, 8:03 AM Reply   
James: very impressive.. want to built me one?
Old    Nu Bu (05mobiuslsv)      Join Date: Apr 2006       04-06-2011, 8:48 AM Reply   
Travis what amp is it , how many channels, and which model Polks do you have.
Old    Travis Zajic (travisz)      Join Date: Jun 2008       04-06-2011, 9:40 AM Reply   
Nu Bu;
I know for a fact they are brand new Polk MM 651 (FYI they crank and are super loud, when they are working)
I believe the amp that is in there is an older 2 ch 400 watt amp its a digital audio
I am looking at switching it to a new 2 ch 500 MTX
johnny and liquid trends said for the time it was a decent amp they sold it as a package at the dealer back in 06
Old    Earmark Marine (david_e_m)      Join Date: Jul 2008       04-06-2011, 9:51 AM Reply   
travizs,
If those are the non-UM MM 2.7 ohm Polks and they are paralleled two per channel on a two-channel amplifier for a net 1.35 ohm load then that would definitely thermal. And, a fan is not the remedy for that scenerio.

David
Earmark Marine
Old    Earmark Marine (david_e_m)      Join Date: Jul 2008       04-06-2011, 10:02 AM Reply   
travizs,
If you have four 2.7 ohm speakers your best bet is to bridge a four-channel amplifier into two channels and series the speakers on each channel for a net 5.4 ohm load.

David
Earmark Marine
Old    Travis Zajic (travisz)      Join Date: Jun 2008       04-06-2011, 10:11 AM Reply   
Sweet I actually have a 4 channel amp I can use.. Looks like I have a new project on my hands... along with adding more LEDs.
Old    Nu Bu (05mobiuslsv)      Join Date: Apr 2006       04-06-2011, 10:25 AM Reply   
Travis looks like David jumped in there and finished where I was going with my questions. I figured your amp was seeing an impedance to low making it unstable.
Old    James (Silverbullet555)      Join Date: May 2010       04-06-2011, 5:09 PM Reply   
Quote:
Originally Posted by travisz View Post
James: very impressive.. want to built me one?
I'm not cheap!

To the OP, sounds like you might have figured out the problem and that is awesome!
Old    Andrew"Jet"Mitchell (andrewjet)      Join Date: Jan 2003       04-10-2011, 12:04 PM Reply   
OK ventilation is my specialty. I own a solar attic fan ventilation company for cooling attics. Your amp compartment is the same as your closed attic is..you need air circulation, BUT! More importantly you need to get that HOT air OUT!! You can put all of the fans in there you want but you will just circulate HOT air. Getting the HOT air out is more important than blowing hot air over them. I have a closed bow supra with the same problem..but only seems to happen when Im at party cove?? Hmm?? My plan is to install a small solar powered fan up in the nose and hide the little solar panel somewhere and suck all of the hot air out. You can add a bilge blower but it adds to draining of your battery. I will do a DIY thread later on it after I get the floor and other upgrades done. Concentrate on removing the hot air, and that will fix your problem. Jet

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:51 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us