Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Frank Rose (04avyboarder)      Join Date: May 2012       06-10-2014, 9:17 AM Reply   
I have a pair of rev 8's need an amp to push them. Any thoughts?
Old    Ryan Bush (ryanbush11)      Join Date: May 2003       06-10-2014, 9:55 AM Reply   
300 watts per speakers with the PPI and 400 watts per speakers with the Wetsounds... seems like an easy choice to me!
Old    David (DavidAnalog)      Join Date: Sep 2013       06-10-2014, 10:29 AM Reply   
Quote:
Originally Posted by 04avyboarder View Post
I have a pair of rev 8's need an amp to push them. Any thoughts?
That's a no brainer if you are bridging full range (or in the highpass mode). Definitely the Wetsounds Syn4! Check out the Syn4 configuration switches. It's made for this function so that you have a proper symmetrical signal when bridged.
Old     (cal2vin)      Join Date: Jun 2010       06-10-2014, 11:11 AM Reply   
I've had both of these amps to power a set of pro 80s before the revs came out. The syn 4 was a bit louder but much larger and about 2.5 times the price.
Old    Tracktor (tracktor)      Join Date: Sep 2005       06-10-2014, 12:35 PM Reply   
As you see fror my other thread I am a bit frugal when it comes to my boat? I tried a PPI 900.4 for a pair of pro80's and was underwhelmed. It may also be a set-up issue as it seems others have had decent results from them, though. I only used it a couple of times before tracking down a used Alpine............
Old    Frank Rose (04avyboarder)      Join Date: May 2012       06-10-2014, 1:30 PM Reply   
The ppi is actually 450x2 rms vs the 400x2 from the syn4. Has anyone had real experience with both amps?
Old    Frank Rose (04avyboarder)      Join Date: May 2012       06-10-2014, 1:33 PM Reply   
Calvin, if you had to do it again would you spend the extra $ for the syn4?
Old    Hate N Pain (hatepain)      Join Date: Aug 2006       06-10-2014, 3:38 PM Reply   
The PPI is good enough for my golf cart but let's face it, most the time in the world you get what you pay for. You dropped the cash for top notch speakers why not round it out with a comparable amp. I'm not saying it has to be WS but some think akin.
Old    Frank Rose (04avyboarder)      Join Date: May 2012       06-10-2014, 8:45 PM Reply   
So last season, I installed the rev 8's and a p900.4. I was pretty happy with the set up after tuning with a dd1. Long story short I skipped a few steps this winter and never pulled the battery or put a container of damprid. Lesson learned as I spent last weekend cleaning mildew. Around mid January I was awakened by my revs screaming around 3am. I pulled the rca cables and finally got around to diagnosing the problem last weekend. Found the ppi to have shorted out likely from water damage. I am weighing options on whether to buy another ppi $199 (its death was likely caused by my laziness) or shell out for a syn 4. $599. Looking for feedback from anyone who has experience with both amps, I know that I likely wouldn't have had the same issue with the syn because it's marine. Just torn on whether it's worth spending 3x the cost of the ppi.
Old    BLAIR BARHAM (jonblarc7)      Join Date: Jul 2006       06-11-2014, 12:58 PM Reply   
I have the PPI on one set of REV10's and my buddy has a sync4 on a set of rev 10 and the sync is louder and sound alittle better but not by much. If my PPI goes bad I'll just shell out the extra money for the sync so it won't happen again. But for now I'm happy.
Old     (cal2vin)      Join Date: Jun 2010       06-14-2014, 5:40 PM Reply   
Id probably go with a syn4 if I did it again.
Old    Chattwake (chattwake)      Join Date: Jan 2010       06-16-2014, 6:57 AM Reply   
Syn4 all the way.
Old    Craig (ccelia)      Join Date: Sep 2009       07-01-2014, 8:58 AM Reply   
Anyone with a PPI 900.4 powering Wetsounds Rev 10s care to share their settings. I am having a difficult time dialiing in the frequency since the PPI amp doesn't have any numbers b/w the 20hz and the 400hz on the dial. Or is there any other way to ensure that I am set at the proper frequency?

Also, about how far up do you have your gains turned up? I am just looking for a starting point to tune my amp.
Old    Brad Morring (BradM07SS)      Join Date: Jul 2011       07-01-2014, 9:36 AM Reply   
Can't help you with the gain everyones pre-amp voltage is different so you'll have to determine that. But had my crossover around the 8:30 - 9:00 postiion.
Old    Craig (ccelia)      Join Date: Sep 2009       07-01-2014, 12:06 PM Reply   
Thanks Brad, I appreciate the help.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 1:56 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us