Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Dave Diaz (wakebrdr94)      Join Date: Jul 2010       09-29-2010, 4:39 PM Reply   
02 VLX, just hooked up the hose to run and no water is coming out the back. Just making sure this is probably a bad impeller. Also, I heard they are ridiculously hard to get to on this boat????
Old     (packrat)      Join Date: Mar 2005       09-29-2010, 4:43 PM Reply   
Hopefully you hooked up to the intake grate and not one of the ballast grates.
Old    Dave Diaz (wakebrdr94)      Join Date: Jul 2010       09-29-2010, 5:54 PM Reply   
sounds like an answer I would give. I may not know much, but I do know I hooked it up correctly over the last 8 years
Old    Ian Scarlet (imscarlet)      Join Date: Mar 2008       09-29-2010, 7:08 PM Reply   
Did you check that your strainers not blocked?
Old    Dave Diaz (wakebrdr94)      Join Date: Jul 2010       09-29-2010, 7:23 PM Reply   
i did, actually just checked before I came to check this thread
Old    Ron (ronskal)      Join Date: Jul 2006       09-30-2010, 5:34 AM Reply   
Quote:
Originally Posted by wakebrdr94 View Post
sounds like an answer I would give. I may not know much, but I do know I hooked it up correctly over the last 8 years
When was the last time the impeller was changed?

Actually, just plan on changing the impelller if you have more than one season on it. It may be hard to change with the pump installed but you can remove the pump and change it on the bench. My 04 X2 was too hard to change installed due to the muffler/collector right against it so I just removed the pump.
Old    Wa^RON1X^ke (boarder82)      Join Date: Jun 2009       09-30-2010, 6:30 AM Reply   
If it has been a while since the last impeller change, just put a new one in. I just replaced the impeller in our 03 VLX. Sort of difficult to get to, but not horrible. Bump the starter to help remove the old.

Last edited by boarder82; 09-30-2010 at 6:33 AM.
Old    AtTheLake (bmartin)      Join Date: Jan 2007       09-30-2010, 10:55 AM Reply   
If you are replacing, try a Globe Blue impeller. They claim they cun run dry a couple of minutes without shredding and are supposed to last longer. They do seem more pliable than standard black. Got one season out of mine and going for two next year and not planning of replacing it unless if fails.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:09 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us