Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Video and Photography

Share 
Reply
 
Thread Tools Display Modes
Old    Brant Williams (kitewake)      Join Date: Jul 2007       08-01-2010, 12:16 AM Reply   
The first two times I tried shooting from the tube with a water housing for my D300 were not so good. Lots of issues with water on the lens port. I made a special squeege using a windshield wiper and a wooden handle...and very few images were ruined by water drops this time. Vics at about 9:30-11 a.m. ....so the light was not that great.

Here are a few....











Plus a few from the boat...



Old    Joe Umali (dakid)      Join Date: Feb 2001       08-01-2010, 12:17 AM Reply   
sick
Old    Brant Williams (kitewake)      Join Date: Jul 2007       08-01-2010, 12:17 AM Reply   
How come I can't get images to post? I have never been able to get an image to post here....lame.

Here is the URL...

http://www.flickr.com/photos/wakesho...7624626921348/
Old    Joe Umali (dakid)      Join Date: Feb 2001       08-01-2010, 12:20 AM Reply   
too bad the rider's wearing a helmet...not good for pics unless he's hitting rails. but that's just me.
Old    Brant Williams (kitewake)      Join Date: Jul 2007       08-01-2010, 12:21 AM Reply   
Equipment...
D300
17-35 f/2.8
Aquatech Water Housing
SB900 w/Flash Housing

Last edited by kitewake; 08-01-2010 at 12:28 AM.
Old    Rob VLX (skull)      Join Date: May 2002       08-01-2010, 5:30 AM Reply   
Sweet shots.... go to Share, select "Get HTML", select "Large" and copy and past it here.

_ACT2653
Old    Brant Williams (kitewake)      Join Date: Jul 2007       08-01-2010, 9:19 AM Reply   
'Share'? Where do you find that? I can't find that anywhere on the thread options... Thanks...

Last edited by kitewake; 08-01-2010 at 9:24 AM.
Old    Brant Williams (kitewake)      Join Date: Jul 2007       08-01-2010, 9:46 AM Reply   
OK...I think I have it now... Can't use large though....it said its too big... How do you guys all post those large images?!
Attached Images
 
Old    Mario (mdaijogo)      Join Date: Mar 2010       08-08-2010, 4:31 PM Reply   
Good to see others using the helmet!

Nice shots BTW.

m-
Old    stephen gee (dellagucci)      Join Date: Aug 2009       08-12-2010, 1:44 AM Reply   
sweet shots brant! lets do it late evening on whiskey!!
Old    Arek (splashbenidorm)      Join Date: Apr 2007       09-01-2010, 11:53 AM Reply   
Aquatech Water Housing, wow!

that`s an expensive toy!

Great pics, a really pro job.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:13 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us