Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Chase Tillett (tn_rider)      Join Date: Dec 2009       08-13-2010, 9:20 PM Reply   
just pulled the trigger on a 2003 malibu wakesetter VLX and the perfect pass is giving me some trouble! when i turn on the perfect pass and take off it will get up to speed but is slow getting up to speed..the boats speed is fine but the digital mph on the perfect pass is slow. it gets up to speed and beeps and has the lines under the mph like its supposed to but its like it doesnt catch the speed or something, any help would be amazing!!....the only other thing is the gas gauge isnt working properly, any info on that would be helpful as well!! thanks so much

chase
Old    mikebu (mikebu)      Join Date: Aug 2008       08-14-2010, 11:24 AM Reply   
Take a look at the manual http://www.perfectpass.com/pp_support_usersmanual.html and maybe try tweaking some of the config numbers...
Old    Bruce Mac (brucemac)      Join Date: Dec 2005       08-14-2010, 8:23 PM Reply   
check all your connections, make sure the pins are snug in the molex-style gromets back at the servo.
Old    Art (rallyart)      Join Date: Nov 2006       08-14-2010, 10:10 PM Reply   
Chase, it is normal for the speed to overshoot a little and then slow down to the correct speed. It will also accelerate a little slow as you add throttle when you are coming up to speed because the servo winds up some of the throttle cable. Perhaps that is what your are describing. If it's different or i"ve misunderstood then post more details.
Old    Tre (tre)      Join Date: Jul 2002       08-15-2010, 8:19 AM Reply   
Perfect pass: So is the boat not getting up to speed or is it going over the speed you set?

Gas guage: may be a bad sending unit. You can short the two wires on the sending unit (on top of the tank) with a screwdriver or another wire and that should make the guade read full. If it does, you know the guage is good and the sending unit is bad. If it does not read full, your guage could be bad or a wire to the guage can be bad (or disconnected).
Old    Brandon Key (bkey79)      Join Date: May 2010       08-16-2010, 8:16 AM Reply   
Check out www.themalibucrew.com on the gas gauge. I had a bu and had problems with the gas gauge also. As soon as it went under a half tank, it went to empty. They have a fix for it on their site.
Old    Tim (srock)      Join Date: Mar 2002       08-16-2010, 9:31 AM Reply   
Sounds like you don't have enough throttle and the unit is working at the slow end of its limit. Does it settle in if you give it more throttle when it beeps and gives the lines?
Old    Jeremy (wake77)      Join Date: Jan 2009       08-16-2010, 10:48 AM Reply   
If it is having a hard time getting up to speed, the filter is set too high. This is the PW setting. When it is too high, the boat will approach your set speed, but a few tenths of a MPH before reaching it, PP will decrease the throttle. Check this setting and then lower it. We had this same issue, especially when weighted down more.
Old    Chase Tillett (tn_rider)      Join Date: Dec 2009       08-17-2010, 2:19 PM Reply   
when i turn the key isnt the servo supposed to kinda tick clockwise? when i turn the key it sounds like it wants to tick but cant...when i get up to speed the perfect pass will beep like its supposed to but wont "catch the speed"...its like its not even on at all.
Old    Jeremy (wake77)      Join Date: Jan 2009       08-17-2010, 4:02 PM Reply   
Check your KW and NW settings.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:24 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us