Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Dave Kiehl (dave27)      Join Date: May 2005       03-09-2010, 11:52 AM Reply   
I just ordered two pumps as back ups. They do fail. Anyway I am just letting you guys know where I buy them.

http://www.keenzo.com/showproduct.asp?ID=3053888

Its a Piranha dual port livewell pump p/n SHU 35710310
Old    Ken (ghostrider_2)      Join Date: Aug 2004       03-09-2010, 12:02 PM Reply   
never had one completely fail. I do have one that has an additude and sometimes I need to bump reverse to get it to suck.
Old    Dave Kiehl (dave27)      Join Date: May 2005       03-09-2010, 12:06 PM Reply   
There is no reverse on these pumps. We have a fill pump and a drain pump. But I will say this, I have had many priming issues with the rear hard take pumps. I found one to be cracked (do to a freeze, maybe?) and one the motor just failed b/c water got into is some how. There are 6 of these pumps on our boats.
Old    Sparky Jay (wake_upppp)      Join Date: Nov 2003       03-09-2010, 12:57 PM Reply   
That is the correct pump. I replaced one on my 06 and bought it locally at MarineMax and it was about the same price.
Old    Ken (ghostrider_2)      Join Date: Aug 2004       03-09-2010, 1:30 PM Reply   
I was referring bump the boat in reverse and it would start the suction.
Old    Spencer (spencerwm)      Join Date: Feb 2009       03-10-2010, 9:14 AM Reply   
Dave you test that ballast system yet or are you waiting to get new pumps installed?
Old    Dave Kiehl (dave27)      Join Date: May 2005       03-10-2010, 9:45 AM Reply   
Spencer, I am waiting on getting my boat back and to stop working OT. I want to finish this month long project and test it, then ride it. I only bought these pumps as spares. I do a week long trip and I would hate for one to go out, as they seem to.
Old    Derek (camassanger)      Join Date: Oct 2009       06-06-2010, 12:10 PM Reply   
Just went to test out my new ballast system - got about 7/8" full and the pump gave out. Thanks for this reminder Dave - I have one on hand and am switching it out today.

PS: Wake looks awesome now - cant wait for the other 1/8 :-)

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:27 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us