Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Wakesurfing

Share 
Reply
 
Thread Tools Display Modes
Old    JF (inland_surfer)      Join Date: Aug 2002       05-24-2010, 9:22 AM Reply   
"Two Guys and a Camera" installing a extra ballast pump on a 2010 Centurion Enzo.


http://www.youtube.com/watch?v=Zh12FOpB0oM
Old    WAlove (masonwakerider)      Join Date: May 2003       05-25-2010, 7:35 AM Reply   
good install video, don't forget sealant on the thru hull. Also some boats (mastercraft) seem to have issues with powering extra ballast pumps from the dash circuit board. The pumps draw a good amount of current that the board was not designed for. We would some times see issues with the gauges and the stereo head unit, especially if the battery is old and sits a little low. We would run the ballast puppies right off the battery are add a separate fuse panel.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:17 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us