Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old     (Bakes)      Join Date: Mar 2010       05-17-2010, 6:18 PM Reply   
Anybody have a list of the usual suspects for a leak at the back of my 98 Mercruiser MPI? I thought it might be the impeller housing but I have swapped it out twice and then bought a new housing and it still leaks. I wish I had checked for leaks before swapping that stupid thing out. Anyways, it is at the back of the engine and nearly impossible to see where it is coming out. The flywheel just flicks bits of water out continually. The drops collect on the water pump on one side and on the shower T connector on the other side. Somewhere water is dripping onto the flywheel. Anybody have any recommendations? Are there any plugs around there that may not have gotten sealed back up? It isn't a big leak, about a drop every 4-5 seconds but I would prefer if it did not leak

Thanks

Bakes
Old    Seahawks #1 Fan Robert T (cwb4me)      Join Date: Apr 2010       05-17-2010, 6:22 PM Reply   
need a picture
Old    Aaron Ware (99_slaunch)      Join Date: Oct 2005       05-17-2010, 6:34 PM Reply   
You say the fly wheel flicks water out continually and the drops collect on the water pump???? The fly wheel is at the back of the motor and the water pump is up front. There are 3 freeze plugs on the back of the block behind the fly wheel if I'm not mistaken. The water pump has a weep hole on the bottom and if it leaks the pump is bad. Inspection mirrors/dental mirrors are a great tool to have.
Old     (Bakes)      Join Date: Mar 2010       05-17-2010, 7:19 PM Reply   
Hmmm. What I mean by the flywheel is the thick metal (I think) wheel that looks like it is attached to the camshaft at the front of the engine. The leak is technically at the the front of the engine (where the serpentine belt is). I don't have a good pic. I don't think my seawater pump has a weep hole. It is a brand new pump assembly so I don't think it is the culprit.

Anyways, any assistance from someone who has found a mystery leak somewhere near the water pump and serpentine belts on a mercruiser 350 MPI is appreciated

Thanks

Troy
Old    Johnny (johnny_defacto)      Join Date: Sep 2006       05-17-2010, 8:06 PM Reply   
sounds like my leak, same motor in my 98 tige. check your circulation water pump since your seawater pump has been replaced. like Aaron said, check the weep hole (with a mirror if you can), if water is coming out, you need to change the pump. I did not catch my leak until the weep hole plugged and then I had a real bad leak from my water pump. easy fix.
Old    Aaron Ware (99_slaunch)      Join Date: Oct 2005       05-17-2010, 8:15 PM Reply   
The thick metal ring attached to the CRANK is called a harmonic balancer. The water pump is just above the balancer. the water pump has a very small hole on the bottom of it. Look at this link. The weep hole is at about the 6 o'clock position from the black pulley flange.

http://cgi.ebay.com/ebaymotors/Chevy...item3a5ace7c07
Old     (Bakes)      Join Date: Mar 2010       05-18-2010, 6:07 AM Reply   
Thanks...that makes a lot of sense and fits perfectly where I am finding water. I'll see if I can't swap it out in the next couple of days

Later

Bakes
Old    Steve Oh (olskooltige)      Join Date: Mar 2007       05-18-2010, 7:28 AM Reply   
Water pump.
http://cgi.ebay.com/ebaymotors/350-c...ht_2933wt_1022
Old     (Bakes)      Join Date: Mar 2010       05-20-2010, 6:39 PM Reply   
Swapped it out today. Pretty simple even though a V-Drive. No leaks now and that pesky little squeal went away as well. Hopefully this will get me through the summer. So far I've swapped out the distributor cap, the seawater pump (3 times looking for this leak) and now the engine circulation pump..I'm about all maintenanced out

Thanks for the advice...who knew these things had 2 water pumps

Later

Bakes

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:43 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us