Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Blake Hughes (blake_hughes)      Join Date: May 2004       05-12-2010, 10:08 PM Reply   
At some point, someone removed the seat on my X-Star and brutually reinstalled it. It looks like there were 6 small screws used originally... Somehow that ended up being a couple small screws and a couple 1/8"-1/4" lag bolts smothered in caulking! The lag-bolts were stripped on installation, due to the 1/2" shoulder.

Any ideas how to fix this? I'm looking to remount the brackets and never take them off again. As far as I know, the black piece that the brackets mount to is part of the floor... There's no way to access the underside of that piece.

Thanks!
Attached Images
  
Old    JUST-IN-TIME (justintime)      Join Date: Mar 2009       05-12-2010, 11:11 PM Reply   
you could always install a pedestal swivel seat
Old    Swatguy (xstarrider)      Join Date: Jun 2007       05-12-2010, 11:44 PM Reply   
I am pretty sure that black part comes off. Not 100% but thought it did
Old    Blake Hughes (blake_hughes)      Join Date: May 2004       05-13-2010, 12:16 AM Reply   
Quote:
you could always install a pedestal swivel seat
That's not a bad idea... My seat does not swivel, that would be a nice option. Thanks for the idea!

Quote:
I am pretty sure that black part comes off.
I thought so too... But I didn't get to investigate that option very much. I'll take another look. I have a feeling there might be some fasteners under the rubber trim... I hope so!

Thanks guys!
Old    Swatguy (xstarrider)      Join Date: Jun 2007       05-13-2010, 7:52 AM Reply   
Yup for sure it pops off. Checked last nite and my base doesn't have the rubber outline and there are about 9 screws to pop that off .
Old    Blake Hughes (blake_hughes)      Join Date: May 2004       05-13-2010, 10:51 AM Reply   
Swatguy...
I was stoked to read your post... But as my luck would have it... Mine does not unscrew. I removed the rubber trim, but there were no screws. I thought there might be a lip at the base so I peeled the carpet back... I didn't see anything there either.

My buddy suggested removing the floor panel that covers the fuel tank... He thinks I can reach the bottom side of the seat from there... My fingers are crossed!
Old    Trace (trace)      Join Date: Feb 2002       05-13-2010, 11:23 AM Reply   
Just clean up the holes, fill them with Marine Tex, redrill, and use new stainless screws. No need to access the bottom side IMO.
Old    Phatboypimp (phatboypimp)      Join Date: Apr 2005       05-13-2010, 11:31 AM Reply   
10:1 that it came from the factory that way, that is exactly what mine looked like. lol.
Old    Swatguy (xstarrider)      Join Date: Jun 2007       05-13-2010, 11:56 AM Reply   
Huh........who would have known. Mine is a 2000 so maybe they tweaked the mold a bit since that was the first year of the new top mold that is still used today. Like Others have said maybe shift the rail mounting position. To pull up my floor I just grip the ring where the plug is on the floor and give a good two hand pull. The key is to slide the floor out forward and keep it as level as possible. Comes right up. On some of the newer boats though you actually have to remove the middle section of the rear seat as the carpet causes it to hang up a bit.

Also check out www.mastercraft.com/teamtalk lot of much more knowledgeaboe guys who take things aprt more often than myself

Last edited by xstarrider; 05-13-2010 at 12:05 PM.
Old    Blake Hughes (blake_hughes)      Join Date: May 2004       05-13-2010, 12:07 PM Reply   
Trace,
I agree, that's a option, but there's already damage to the fiberglass around the screw holes... There are spider cracks extending 2" from the holes in all directions. I'm afraid drilling more/new holes will weaken the fiberglass even more, causing a huge headache down the road. I may have to use that option as my last resort. If I can, I'll get access to the bottom side and fabricate a pair of plates for the top and bottom... When I install them, I'll throw down a layer of sealant between the fiberglass and the plates. Hopefully I can manage to pull that off.

Phatboypimp,
I hear ya... The more I work around these boats the more I realize they weren't built very well.

Swatguy,
Let's chalk it up to my luck... Lol. I'll try pulling the panel off in a little bit.
Old    Swatguy (xstarrider)      Join Date: Jun 2007       05-13-2010, 12:07 PM Reply   
guess they tweaked the mold for 01 then. Mine is 2000 and that was the first year of that new top deck arrangement.

Also try www.mastercraft.com/teamtalk Guys over there take things apart waaaaaaay more often than I do.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:59 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us