Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Danny Simon (wakerider42)      Join Date: May 2002       05-04-2010, 10:09 PM Reply   
First ride since dislocating my shoulder last August and shoulder surgery blah blah. And the damn belt on my '02 Malibu VLX breaks! Dammit!! Well, I guess I should replace it more often than once every 4 years...at least I got my run in.

Anywho, after it broke I pulled out the remnants and just drove back to the dock, like a 1 minute drive, no overheating or anything, BUT I just want to make sure I don't need to replace the impeller.

The impeller seems to be driven off the main crank pulley, in which case maybe it still had water passing by it. At the same time, the engine water pump is driven by the belt, and so was obviously not turning, but I don't know if that extra draw is needed to pull water past the impeller to avoid it burning up.

Probably ran about 4 or 5 minutes total with no belt.

Thanks guys,
Danny
Old    Bawshogg (bawshogg)      Join Date: Dec 2005       05-04-2010, 10:35 PM Reply   
The Impeller is a lift pump in a simple form. All it does is supply water to the waterpump to be circulated through the motor. I would suspect that the impeller is fine as it was still sucking water and was lubricated. As long as the engine didn't overheat I would suspect no damage done other than the belt.

Last edited by bawshogg; 05-04-2010 at 10:36 PM. Reason: sp
Old    Mikeski (mikeski)      Join Date: Aug 2003       05-04-2010, 10:44 PM Reply   
Indmar raw water pumps couple directly to the crank pulley so it is fine. The circulation pump does run off the belt so it will overheat if you run it longer than a 10-15 minutes. Actually, neither pump will be hurt from not turning, but the motor will overheat from lack of cooling water. Just replace the belt and you should be good to go.
Old    Danny Simon (wakerider42)      Join Date: May 2002       05-05-2010, 1:08 PM Reply   
Cool, thanks guys, that's what I thought based on just looking at the physical arrangement, but I wanted to be sure. I've got a crap ton of other stuff to do, so I'll just sack up and do it all at once. Owning a boat sucks sometimes!!! Break Out Another Thousand for shizzle.
Old    WakeMikey (wakemikey)      Join Date: Mar 2008       05-06-2010, 12:11 PM Reply   
Yes the impellor turns if the alt belt is broken. Your batteries, however, will not be charging and after a few starts you would need to hook them up to a battery charger for an overnight recharge. I always carry a few alt belts.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:48 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us