Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    David D (wakeguru)      Join Date: Feb 2003       04-23-2010, 7:48 AM Reply   
Check your impeller!

I had put it off, along with other maintenance, and have been burning up the lake lately................well, go out last night and sitting at idle and suddenly there is a strange friction noise under the hood (direct drive MC x-5)...........thought "rutt roh" sounds like da impeller.

Turned boat off, tossed anchor, pulled the pump cover and sho 'nuff, busted up impeller but still in nearly one piece - it was on the verge of busting up completely though. LUCKY.

FORTUNATELY, I kept a decent one in the glove box from when I changed it out back when I can't remember. Screw driver, needle nose vise-grip plyers, and a little barbasol shaving cream and a bump of the ignition to spread the cream on the old impeller, and she comes out like butter (shot shaving cream out at wife and son though LOL).

Busted up "props" on the impeller so I pulled the feed lines and found all (I think!) of the missing pieces.

20 minutes later back in business and riding. Could of been an overheated motor and much more expensive and PITA fix.

Just a friendly reminder....it's a $34 part at skidim and not that hard to change (on a direct drive, anyhow)......happy boarding.
Attached Images
  
Old    Jason B (boomboom)      Join Date: Apr 2008       04-23-2010, 8:11 AM Reply   
yeah...not so easy on a V-drive. lol
Old    David D (wakeguru)      Join Date: Feb 2003       04-23-2010, 8:15 AM Reply   
so I hear.

you have a better wake if it makes ya feel better about playing curse word twister to change it out.
Old    Adam R (wakecumberland)      Join Date: Oct 2007       04-23-2010, 8:23 AM Reply   
I forgot to turn the valve back on after I replaced my impeller this year and thought I had burnt up the impeller. I pulled it out on the water and luckily it was fine. However, after swaping out the impeller 3 times since owning my X2, I wouldn't wish that job on my worst enemy! Luckily I have gotten faster at it and can have one out and back in in about 20 mins. Total PITA though!
Old    Mattgettel (mattgettel)      Join Date: Jan 2009       04-23-2010, 9:13 AM Reply   
i just had mine changed last year but i think that i will check it out before hitting the water. thanks man.
Old    Mario (mdaijogo)      Join Date: Mar 2010       04-23-2010, 9:23 AM Reply   
I'd take this type of job vs. replacing the impeller on my old i/o.

Nice save.

Mario-
Old    Bret Ski (younguns44)      Join Date: Jan 2010       04-23-2010, 9:27 AM Reply   
how long had you gone since you changed it?
Old    owen sealy (osealy)      Join Date: Aug 2006       04-23-2010, 9:28 AM Reply   
Hey Dave D is that a cartridge pump fixed to the centre drain under the motor for ballast??
I was planning to go that way with a reversible pump to save cutting an extra hole. Prostar 190.
Old    David D (wakeguru)      Join Date: Feb 2003       04-23-2010, 10:36 AM Reply   
sealy - it kinda looks that way, but that's just the regular bilge pump at bottom of hull. my boat is basically a prostart 190 with a tower.

auto ballast would be a nice upgrade and I wouldn't want to cut into the hull either!

we run a fat seat in the back and one 350# (Launch Pad side sack) in front of engine...or, if we have a lot of riders in the boat or are just taking it easy, we'll do the two side sacks - one on each side of motor.

bret ski - not sure, but I'm guessing around 3 years. riding slowed in recent years, so we had not been putting many hours on the boat. I had been changing it once a year and even when I was putting 100+ hours on the boat in a year, the impeller was always in pretty good shape (at least appearance-wise) when I changed them out. Regardless, I would not go over 2 years before changing it out no matter how many hours you put on....do it once a year for absolute piece of mind and forget about it.

impeller life span may also depend on the quality of water that you are drawing from...if you beach the boat a lot, you could suck up more dirt and debris and put more wear on the impeller (buddy over-heated his 210 one time backing out super hard off the beach and sucking sand). we don't beach it that often since we mostly ride on our lake and tie to the dock so that may be why mine have lasted a bit longer or been in good shape when changed after a year.

thank goodness I was sitting at idle when the impeller started to come undone. I might not have heard the funny noise otherwise. I'll probably always carry a spare and the tools after this.

Last edited by wakeguru; 04-23-2010 at 10:43 AM.
Old    Small Light (stephan)      Join Date: Nov 2002       04-23-2010, 10:43 AM Reply   
Owen, that is the bilge pump.

The DD Mastercrafts are very easy to replace, this very reason is why we keep a spare in the glove box. Our '98 205D has the LT-1 and it seems to eat impellers regularly. It always does it right after start up, just gotta keep an eye on the temp. Scary with the aluminum heads.

I know I've posted this in the past, but... if you get stuck out in the lake with a fried impeller, use a fat sac pump to direct water into the block. You can't go fast but its a McGyver way to limp back to the ramp.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:12 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us