Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old    Ken (ghostrider_2)      Join Date: Aug 2004       02-28-2010, 8:37 PM Reply   
Today was good until I found both batteries gone, dead, ka-put! I replaced the starting battery tonight with one that was on sale from Bass Pro Shops, $89 for 1000 cca 3 year war. Havent replaced the deep cycle yet. I put the new battery in, did a volt meter check just because, turned the key to acc and nothing. The battery is good because the docking lights are bright. I am wondering if for some reason I need both batteries hooked up to complete the cycle/circuit so to say?

As for the deep cycle I am leaning towards the Die Hard from Sears, anybody have any good input? I am only running 2 amps, 10' woofer, 4 - 6x9's and 4 - 6 1/4's. We only hang with the music at most 2-4 hours in a cove a day. Thanks

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 1:41 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us