Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through August 27, 2003

Share 
Reply
 
Thread Tools Display Modes
Old    carl beck (mainelaker)      Join Date: Feb 2003       08-24-2003, 3:07 PM Reply   
I have a new Centurion Hurricane & I installed perfect pass this weekend. It hunts about 1.5 miles an hour with a rider. I think the problem is b/c the throttle cable increases in angle from the bracket to the throttle body then the PP installs on the cable & will drop down due to the location of the servo on the exhaust hose. I think if I could create a bracket to keep the PP cable at the right height it wouldn't hunt as much. It states in the install manual to not have any gap between the PP cable & throttle cable but how can you do that when it doesn't have a rigid connection to the cable? Quite frankly I think the servo part of the system is a little cheesy & they should have thought the design out a little better. I'm sure the slight gap is the cause of my problems but how do I solve it?
Old    Trace (trace)      Join Date: Feb 2002       08-24-2003, 5:34 PM Reply   
i have a Vdrive, but i had a similar problem. my cable had a tight bend in it when it was mounted to the cooling hose. i made a bracket for mine & mounted it under the deck in the starboard rear storage. this also isolated it from heat of the exhaust risers. here's a pic with the compartment divider down:
engine
the servo should remove all the slack from the cable when the PP unit is powered up. there shouldn't be a "gap", but i don't think it's a big deal if there's a bend in the cable between the fittings, as long as the fittings are all pulled together when you're idling in neutral.
Old    Kevin R Baugh (krbaugh)      Join Date: Mar 2002       08-24-2003, 8:08 PM Reply   
Does it do this is MPH mode and RPM mode?

If it holds speed good in RPM mode and fluctuates in MPH mode it can be 2 things paddle wheel or the computer module.

Call Perfect pass they are a HUGE help
Old    carl beck (mainelaker)      Join Date: Feb 2003       08-25-2003, 2:26 AM Reply   
I haven't tried RPM mode yet & won't be near my boat until next weekend.
Old    Lance (uga33)      Join Date: Jul 2003       08-25-2003, 5:17 AM Reply   
I have a 2002 Hurricane and Installed perfect pass as well. Mine holds real good in calm waters .5 MPH+/-. However, in rough water it is about 1 to 1.5 MPH+/-.
Old    barryb            08-25-2003, 6:12 PM Reply   
The tightness of the bend makes a huge difference.
Set the boat at half throttle (motor off). Then open the motorbox, grab the PP control wheel, and rotate it around. Watch the throttle lever on the engine when you do this. If it moves both in and out perfectly smoothly with your rotation of the wheel, you're in good shape.
If it's at all jerky when you let cable out you have to increase the radius of the bend or it won't work properly.

If it operates smoothly, your problem could be the gain (I believe PP calls it Kx) setting on the cruise control. Higher numbers make the PP unit
respond to changing speeds more quickly.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:52 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us