Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Wakeboarding Discussion Archives > Archive through August 20, 2009

Share 
Reply
 
Thread Tools Display Modes
Old    Carl Ladd (vlxwakeboarder)      Join Date: Jun 2008       08-17-2009, 9:34 PM Reply   
I have the 09 Ronix Ones and love them to death. But I don't care a whole lot for the mounting system. I like how you can adjust them to the smallest of degrees but even with the screws cranked down all the way they move just a tad. Nothing to noticeable but they do move a millimeter or so. They remind me of the claw system hyperlite had and once you rode them hard for a while the claws would wear down and the bindings would begin to slip more. I am starting to miss the old bindings where you put the screw through the whole and there was no chance of movement ever. Does anyone else notice this with their bindings?
Old    VLX Envy (cavlxenvy)      Join Date: Aug 2007       08-17-2009, 10:36 PM Reply   
I have the same bindings and have not noticed this. What board do you have them mounted on? (not that it should matter)
Old    Caleb Rountree (dlwsrider)      Join Date: Apr 2007       08-17-2009, 11:03 PM Reply   
I'm with VLX Envy, never had that problem. Is it on all of the screws? maybe shorter screws are in order.
Old    Jake Hertz (jhertz27)      Join Date: Jul 2005       08-18-2009, 6:58 AM Reply   
Hey Carl,

I have that problem with my set up. I am riding 09 Ronix One bindings on the 08 Mana. I am using the spacers to go out as far as I can, but my back binding always wiggles a few centimeters underneath the spacer, no matter how much I tighten it. I have been riding like that all summer, until recently the threads wore down on the binding. While I was riding the last time, my boot was literally moving an inch or so. I had to stop riding and use my old bindings. Whatís weird is the front binding is just fine. Not sure what I should/could do at this point besides sending my bindings back or get a new board.
Old    Justin Thompson (tchs22)      Join Date: Sep 2005       08-18-2009, 8:48 AM Reply   
yeah i have not even ridden my new 09 reliks but have put them on board and put them on feet and noticed that....BUT my 08 ones do the same thing on Heels...so idk we shall see....oh my 09 reliks are on my 08 murray
Old    Ric Abernathy (ricabernathy)      Join Date: Jun 2009       08-18-2009, 10:05 AM Reply   
i have the 09 ones on my 09 IBEX and mine are snug with no movement..
Old    Steve - O (misteve)      Join Date: Aug 2007       08-18-2009, 10:11 AM Reply   
I've got 09 Cells on an 08 Transcend and they are locked down!
Old    Justin Thompson (tchs22)      Join Date: Sep 2005       08-18-2009, 10:19 AM Reply   
well mine just seem to move on the heels...i cant tell if they are moving via degree and such but i can feel heel movement
Old    Jake Hertz (jhertz27)      Join Date: Jul 2005       08-18-2009, 11:00 AM Reply   
Carl,

Are you using the spacers or just the normal facets?

For me, only the spacer on the inside of the back boot is a problem. However, even with both the spacers I am not able to ride with my bindings out all the way because they reduced the width of the binding base by a couple of inches. I have not had a problem with the normal facets so I guess my only other option would be to move my back boot in two notches and avoid the spacer altogether.
Old    Dave (daveronix199)      Join Date: Feb 2009       08-18-2009, 11:31 AM Reply   
Im having the same problem... Im on an 07 shane with 09 cells front one is locked in back moves like a CM or so... F'ED up
Old    Caleb Rountree (dlwsrider)      Join Date: Apr 2007       08-18-2009, 3:16 PM Reply   
From what I'm seeing it may just be an issue with how shallow the boards mounting holes are from year to year, brand to brand. I've noticed this and have used everything from washers to aluminum can tops to space out the bindings a bit more on older LF boards for friends.

Not sure how to help without shortening the screws though.
Old    Joe Pearson (pearsonville)      Join Date: Feb 2002       08-18-2009, 5:17 PM Reply   
I use the Ronix Relik on my Ronix Viva Perfect fit and they do not move.... Love the system.
Old    Carl Ladd (vlxwakeboarder)      Join Date: Jun 2008       08-18-2009, 6:32 PM Reply   
Hey bros, I have the O9 Ones on the O8 CSV1. I am using the spacers and it is just my back foot. I ride regular and my stance is all the way thus having to use the spacer. I am just worried that this small millimeter of a movement is going to turn into the same problem that Jake is having. I hate spending this kind of money on a setup and having flaws. This is exactly why I wish they would quit with all the fancy gadgets and get back to what works. Put the same boot with the older base plates. I am about to go back to my 01 Hyperlite Highbacks. HAHA
Old    Carl Ladd (vlxwakeboarder)      Join Date: Jun 2008       08-18-2009, 6:41 PM Reply   
One question for those who use the spacers. Would it effect the setup if the spacers go on the outside? I have my spacers on the inside of the bindings.
Old    Carl Ladd (vlxwakeboarder)      Join Date: Jun 2008       08-18-2009, 6:52 PM Reply   
Ok I have tried everything since I got home from work. I have cranked it down as far as possible and still have movement. What is the best way to get in contact with Ronix to discuss this problem?
Old    Jake Hertz (jhertz27)      Join Date: Jul 2005       08-18-2009, 9:50 PM Reply   
Carl I am with you on the frustrations. Unfortunately, my threads are already worn down. I will try and call Ronix tomorrow. Let me know if you get any good info, Iíll do the same. lata.
Old    Jason (black_ops_09)      Join Date: May 2009       08-18-2009, 11:08 PM Reply   
I also have the Ronix Ones, and when I mounted them, they were kinda loose. I just went to Home Depot and got some lock washers, added one to each screw and now they tighten down perfect.
Old    Caleb Rountree (dlwsrider)      Join Date: Apr 2007       08-19-2009, 12:30 AM Reply   
Ronix is very highly regarded about their customer service.

Carl, shoot me an email at crountre@uark.edu, and include where you are from. Not creepin', I may be able to help, haha.
Old    Carl Ladd (vlxwakeboarder)      Join Date: Jun 2008       08-19-2009, 6:42 PM Reply   
Thanks Caleb. I sent you an email.
Old    Swatguy (xstarrider)      Join Date: Jun 2007       08-19-2009, 7:03 PM Reply   
I had a problem with 08 Cells on my 08 Covin. I mean WTF. How can you have a board and binding combo from same mfg and exact same series that doesn't work. However I loved the bindings so much.....I have always just used some stainless washers to soak up the gap esecially back in the day with the Hyperlite claws on a CWB board. One on each bolt did the trick. Locked down for sure. I started doing this a while back.
Old    Justin Thompson (tchs22)      Join Date: Sep 2005       08-19-2009, 8:10 PM Reply   
you using reg washers or lock washers? and how could you do this on the 09s?
Old    Caleb Rountree (dlwsrider)      Join Date: Apr 2007       08-19-2009, 8:22 PM Reply   
Carl, sent you one back. Hope that helps!

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 9:41 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us