Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 28, 2009

Share 
Reply
 
Thread Tools Display Modes
Old    dan (doubleup_dan)      Join Date: Oct 2006       07-15-2009, 9:11 AM Reply   
Im have this problem with my xstar. I have been away for two weeks it was working perfectly before I left but got back today and it is running strange.

It was set at 39KPH and I went to ride but now at 39 it revs alot higher and is going faster. If I put it down to 32kph so it is doing 4000rpm ( normal revs for the speed I ride) it feels a bit slower then I normally ride and the wake is really curling on the left side and a bit mushy on the right side.

Something similar happened before but it was reving more and going slower. I the end they replaced the transmission, fly wheel and prop shaft and it fixed the problem. Though I think it all came from the flywheel cracking.

The wierd thing is that when this happened before I was while I was away for a while too.

The only reason that I can think of is that maybe it hit the bottom while we were away as we live on a reservoir and the water goes down alot even though the dock gets moved alot.

Any way any advise would be apreciated!!
Old    Brett Yates (polarbill)      Join Date: Jun 2003       07-15-2009, 9:20 AM Reply   
How is the transmission fluid level?
Old    gangstar (joe_crawley)      Join Date: Jan 2007       07-15-2009, 9:40 AM Reply   
Are you sure you didn't decalibrate your speedos by accident?
Old    Billy (woreout)      Join Date: Aug 2006       07-15-2009, 12:15 PM Reply   
You need to stay home.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 3:25 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us