Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 08, 2003

Share 
Reply
 
Thread Tools Display Modes
Old    lukem            06-01-2003, 5:15 PM Reply   
we just got our x star it had 10 hours on it. right now it has 60 hours on it. and there is about 7 diffrent things wrong with it. the stereo stoped working, come to find out the amp blew. one speaker blew on the tower. the middle ballast leaks very bad. the back ballast wont fill, and if you get it to fill good luck draining it. clock quit working and there is more but i will stop now. i was wondering if anyone else has had these problems with there x star.
Old    xtigeman            06-01-2003, 6:22 PM Reply   
Stereo issues are user error.

The center ballast bag is known to leak. There is a retrofit valve for it that the solves the problem.

The rear tanks will vapor lock from time to time. Just tap the boat into reverse with the pumps on to prime the pump. That is what I do for my 2001. The 2002 pumps I believe have a retrofit also as the problem is well documented. Do a search and ask dealer to upgrade your pump.

For clock, check the fuse.
Old    Michael (marchamb)      Join Date: Apr 2003       06-01-2003, 9:00 PM Reply   
Ya, the fuse on my amp blows all the time. Put in a bigger one but dosent seem to matter. Also, my middle ballast leaks all the time due to a kink in the hose. The back ballasts fill but sometimes I have to play with the hose comming of the pump to prime it. Bought it new in 2001 and always had these problems. Also had a faulty valve on the tranny and had to get it replaced last year because water got in. Cost me 5 weeks of riding but thank god for the warranty!
Old    Ryan Bush (ryanbush11)      Join Date: May 2003       06-01-2003, 9:31 PM Reply   
Yea, the ballast is a leak in the bag, not a valve. the amp problem is a bad ohm load from the factory, they have the amp down to 2 ohms and it can't handle it very well, also the pumps are airlock proof, but the impellors are too big and need to be shaved down, they have been recalled so take it back to your dealer
Old    sickmx29            06-01-2003, 10:10 PM Reply   
since i bought my 02 x star iv hadto put a new motor, 3 new pump impellors,new blower, new control brain, new seat cusion, new trailor,plus mastercraft recalls.. and a few more things... its all been replaced free, but it gets old!
Old    sickmx29            06-01-2003, 10:10 PM Reply   
since i bought my 02 x star if had to put a new motor, 3 new pump impellors,new blower, new control brain, new seat cusion, new trailor,plus mastercraft recalls.. and a few more things... its all been replaced free, but it gets old!
Old    David D (wakeguru)      Join Date: Feb 2003       06-02-2003, 1:00 PM Reply   
Levi, first what engine do you have and did your engine overheat when the impellor went south and subsequently you had to replace it?
That bites. What happened to the trailer?
I had to change out the ICM (computer module/brain) on my 02' MC with the 310hp. The boat only had 100 hrs when my tach and temp guages starting flailing. Sounds like MC has some electronics issues.
Old    George Palovcak (gpalovcak)      Join Date: May 2003       06-02-2003, 1:47 PM Reply   
I don't have an X-Star but my 2000 205 had the gauges stop working which was the MDC board, got that fixed then my ECM(engine Control Module) went bad boat wouldn't start. Just got the boat this year and have only been out twice.Makes you wonder?? Premium Boat or what?
Old    Ryan Bush (ryanbush11)      Join Date: May 2003       06-02-2003, 1:49 PM Reply   
i had the same problem with my engine and my impellor, ruined the engine, it's been in the shop for a week now
Old    lukem            06-02-2003, 7:10 PM Reply   
doug i would have to disagree that the stereo is the users error. we have never played it loud enough to hear it while riding or anything such. i think clarion amps arnt very good, and i agree with ryan about them not be able to handle 2 ohm load.
Old    andy zarlengo (colorider)      Join Date: Jun 2001       06-02-2003, 7:51 PM Reply   
2000 x-5 and have had to replace the following. nothing. 980 hours too. Knocking on wood at the moment.
Old    Ryan Bush (ryanbush11)      Join Date: May 2003       06-02-2003, 9:23 PM Reply   
yea, clarion amps are very good, is just a mistake at the factory for them to load it down to 2 ohms with the sub on one channel

do you have tower speakers?, we had our local stereo shop put a fosgate 12inch sub where the clarion sub was, and put the sub on the smaller amp that was from the factory for the tower speakers, and put all the mid and high range speakers on one amp, so they can set the filters the way they need to be.
the stereo is alot louder and so much more clear.
Old    sickmx29            06-02-2003, 9:34 PM Reply   
i have the 330hp engine... it threw a rod.. the trailor had a posting out... itslike a recall but they wont fix it until it breaks... anyway the springs collapsed and i had to have myy boat and trailor towed home... but mastercraft made me a new trailor so its all good...
Old    lukem            06-03-2003, 6:40 PM Reply   
ryan, yea we got only 2 tower speakers at the moment, hoping to get more, but i am trying to get the cheapest chrome enclousure i can find, but they are not very cheap. that sounds like a good idea, i guess i never thought of that what you did with your stereo. my freinds dad owns a stereo shop so i will have to have him hook me up. thanks for the tip.
Old    Ryan Bush (ryanbush11)      Join Date: May 2003       06-03-2003, 9:06 PM Reply   
yea, they're about 800 dollars if you can find them cheap, but that's not installed.
Old    Grant Stewart (elmog)      Join Date: Nov 2002       06-06-2003, 12:23 PM Reply   
I have an 01 with 15 hours and the tach died. The PP still works so I am guessing that tach signal is still good and it is just the guage and not an MDC/ICM? Were those boards expensive? Anyone know what the tach should cost?
Old    David D (wakeguru)      Join Date: Feb 2003       06-09-2003, 5:32 AM Reply   
Mine was under warranty, but they said the ICM ran about $550.00. It is my understanding that the Tach and the Temp gauges are tied to the ICM in some way (maybe to shut off engine in case of over heating or tach'ing too high...?).
Not sure how much a Tach gauge would run you though.
Old    Ryan Bush (ryanbush11)      Join Date: May 2003       06-09-2003, 6:50 AM Reply   
the engine won't shut off during over heatimg, believe me i just burnt up the motor in my 02 x star a couple weeks ago, but they got it finished today, and i get to pick it up tommarrow
so i'll be off to the lake
Old    matt moss (mossy44)      Join Date: Oct 2001       06-09-2003, 10:06 AM Reply   
ryan - why did your motor burn up? did it have anything to do with too much weight?
Old    Chaun Keating (big_poppa_pump)      Join Date: Apr 2002       06-09-2003, 10:20 AM Reply   
Ryan, the engine won't completely shut off if it overheats, the Northstar ignition will shut down 1/2 of the cylinders to place the motor in a "limp home" mode. The engine will still run, but it will feel like you are towing a battleship.

I had this happen once when my impeller went out. I only drove it maybe 4-5 minutes in this condition since luckily I was very close to the dock.

For my own peace of mind, I would rather get towed in if it would have been much farther. Its a good idea, I just don't know if I would trust it very far.
Old    NAW (ripr)      Join Date: Mar 2002       06-09-2003, 11:37 AM Reply   
Question for you guys...
How long is the warranty on a new MC tach?
Last summer the gages went south, two new speedos, a new tach, and MDC were installed. Worked fine the rest of the summer and when we took it in for winterization/storage. Got the boat from storage this year (dealer storage/summarization) and the tach didn't work. Turns out the dealer said the speedo pickups that were supposed to self drain, didn't, causing the lines that run to the MDC to become disconnected. On top of that, they said the tach was bad and needed to be replaced again, at our expense (out of warranty)! Of course this is after they already replaced it without a phone call or confirmation, they handed me a bill for $350 and wondered why I looked at them cross eyed! Does this make sense to anyone?
Old    Zack (raider40)      Join Date: Oct 2001       06-09-2003, 11:40 AM Reply   
Anybody having problems on their 02 with their depth gauge continually blinking? Mine constantly flashes making it very hard to gauge depth unless the boat is sitting still.

I haven't had any of the other problems you guys have.
Old    Ryan Bush (ryanbush11)      Join Date: May 2003       06-09-2003, 2:37 PM Reply   
the blinking is because either the water is too deep or you're going too fast, or the combination of going a little too fast in deep water. but it's blinking because it can't pick up how deep the water is.

the impellor came apart and locked up the water pump, but the check engine light didn't come on until too late. salvaged the engine, but it still did about 2 grand worth of damage, not a good start to the year. so much for all the new stereo stuff.
Old    lukem            06-09-2003, 6:20 PM Reply   
i just got my boat back saturday night, they said they had everything fixed/replaced. they replaced the lens on the tower light and they said they fixed the radio, the put 3 new pumps in it and fixed the middle ballast.. get to the lake, the lense is gone, and go out and cruise around just being happy as hell to have my boat back, shut it off getting ready to ride, and then the damn radio does the same thing it did before i took it there. so that dont work no more and then we get back in at night, the middle ballast is leaking you can watch it come out, thing was full of water. so now tomorrow i get to drive another 4 hours (round trip) to take it back. man i get really angry. so the only thing they did in a week and a half is put 3 pumps in it that they had in stock. i am not really happy with them. but i understand that this happens so i am going to just deal with it i guess
Old    xtigeman            06-09-2003, 7:18 PM Reply   
Hey man, I hear you on the clarions not be great amps, but they shouldn't shut off either. If your blowing speakers, chances are your clipping the amp by playing too loud. ABout the only real way to blow spekaers with the power that comes stock. Dealers add the tower speakers and the amp for the tower speakers. Some dealers are clueless about stereo stuff.

If you look and tell me how it is wired and what speakers are run off what, I would be willing to try and help trouble shoot it for you. Maybe I could help come up with a solution for the stereo situation. You may even have a loose wire shorting stuff out.
Old    Ryan Bush (ryanbush11)      Join Date: May 2003       06-09-2003, 11:06 PM Reply   
yea, you have to super glue than lens on, i did it after i lost my second one
Old    Grant Stewart (elmog)      Join Date: Nov 2002       06-10-2003, 5:52 AM Reply   
The warranty on your MC is 1 year (from purchase date of boat, not replacement of last tach).

Mine goes in this week. I wonder what my damage will be. I'm a little perturbed about knowing I'll be facing a $300+ bill on a boat with 15 hours. As Beavis would say, "Dammit dammit dammit!"
Old    Koen Vrints (22parksm)      Join Date: Jan 2003       06-10-2003, 12:42 PM Reply   
I have the 2003 X-2.
KGB already broke, Radio gives an error on rewritable CD's, Bolt's on the alternator broke.
And the steering wheel is loose and it isn't possible to tight.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:07 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us