Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 26, 2009

Share 
Reply
 
Thread Tools Display Modes
Old    Jesse Johnston (watersnake)      Join Date: Jul 2006       03-28-2009, 8:14 PM Reply   
Out at the lake today for the first time this summer and while waiting for a buddy to return from parking the truck, I was idleing. about 100 yards past the 5MPH bouys a loud buzzer went off? temp read about 190-195, threw some oil in it and no help once again within 45 secounds the alarm went off again. Just a guess, could it be the impeller? and how much work is it to change?
Old    Show (bigshow)      Join Date: Feb 2005       03-28-2009, 8:29 PM Reply   
How's your oil pressure? Cracked block, broken oil pump, or bad oil pressure sender?
Old    Craig Glass (my_malibu)      Join Date: Feb 2008       03-28-2009, 8:30 PM Reply   
easy to change but 195 is not that hot
money is on the oil pressure problem but just in case it's the impeller----
you can make the removal tool out of two paint can lid removers or buy one
or use two screw drivers
YOU MUST CHECK THE TRANNY FILTER SCREEN for peaces of the old propeller and junk
hope this helps
fyi you should always care a spare

(Message edited by my_malibu on March 28, 2009)
Old    TigeMike (chpthril)      Join Date: Oct 2007       03-29-2009, 3:40 AM Reply   
195 is too warm, should be about 165*. When was the last time it was run and did you run it on a fake-a-lake before this trip out? I'd pull the impeller just for chits and giggles, it's easy enough to yank out. If impeller looks intact, then back flush the raw water intake.
Old    pete c (saceone)      Join Date: Jan 2009       03-29-2009, 8:54 AM Reply   
''threw some oil in it''


what?
Old    Jesse Johnston (watersnake)      Join Date: Jul 2006       03-29-2009, 9:33 PM Reply   
TigeMike, yes before this trip it was on a fake-a-lake. Is there a "how to guide" anywere on this site for pulling and replacing an impeller and back flusing water intake. I havent had to do any type of work on the boat myself before, but in order to save some dough I want to at least try this time.
Old    TigeMike (chpthril)      Join Date: Oct 2007       03-30-2009, 3:47 AM Reply   
Dont know about here, but check out www.tigeowners.com in the "How To" section. There is one for the Merc and Marine Power engines.
Old    David Clements (dcdave56)      Join Date: Jun 2008       04-03-2009, 10:52 AM Reply   
Drive lube level?
Old    Jesse Johnston (watersnake)      Join Date: Jul 2006       04-03-2009, 1:49 PM Reply   
Drive lube level was good, I'm gonna try the impeller, once I figure out how to change it. It's way over due anyway, 2 years!
Old    Train (ttrigo)      Join Date: Dec 2004       04-03-2009, 1:52 PM Reply   
you should change the impeller every year, regardless of how many hours you put on it. IMO. they dry out with no use as well. carry a spare as well. I am pretty retarded when it comes to engines, but I changed the impeller on my old DD a few years back.
Old    Trace (trace)      Join Date: Feb 2002       04-03-2009, 2:00 PM Reply   
+1 change it every year, and keep the old one for the spare. It is a 20 min job on PCMs and Indmars. Mercruisers are a little more hassle.
Old    Trace (trace)      Join Date: Feb 2002       04-03-2009, 2:00 PM Reply   
...and 195 is too hot.
Old    Stephen Parlett (lettinit)      Join Date: Sep 2008       04-03-2009, 2:18 PM Reply   
I'm leaning towards cracked block. Did you wintererize?
Old    gary cody (pavement_rider)      Join Date: Feb 2009       04-04-2009, 4:49 PM Reply   
my money is on the impellar since it went to 195 and held shes just pumping weak and needs replacement. low oil pressure will genereally cause more than just temp problems. If water is pumping fine and she still heats up then we'll look to that crack in the block or head
Old    JUST-IN-TIME (justintime)      Join Date: Mar 2009       04-04-2009, 5:45 PM Reply   
impeller
if you overheated, better replace t-stat and check exhaust hoses

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 10:04 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us