Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through June 08, 2008

Share 
Reply
 
Thread Tools Display Modes
Old    Jonathan Howell (nu2dagam)      Join Date: May 2004       05-30-2008, 6:00 AM Reply   
I have a 99' supra with 350 CID MPI. The fuel line runs from the tank, through a carter fuel pump, through the fuel/water separator, then through what looks like a secondary fuel pump then through the rail and fuel filter and into the engine. My question is regarding the secondary fuel pump. Are these common on those engines. It almost looks as if it was added after market as the wires that supply power to the carter pump are spliced and ran through a relay then to the secondary (booster) pump. Any help is greatly appreciated as I believe this pump has gone bad.
Old    Jonathan Howell (nu2dagam)      Join Date: May 2004       06-02-2008, 10:52 AM Reply   
Does anyone else know if they have two fuel pumps on their boat?
Old    Jonathan Howell (nu2dagam)      Join Date: May 2004       06-02-2008, 10:53 AM Reply   
Actually I have found out the pump above the fuel/water separator is the high pressure pump and the carter that comes first on the fuel line is a low pressure pump that helps bring the gas from the back of the boat to the front of the engine. Does anyone else have a 2 fuel pump set up? I was just wondering how common this is.
Old    Nate (norcalmalibu)      Join Date: Jun 2004       06-02-2008, 11:54 AM Reply   
Its very common on Mercruisers to have a secondary fuel pump. The booster pump is necessary. Also on some of them their is a little fuel filter right outside of the tank that clogs very easily that will result in low fuel pressure.

I have the black scorpion and it hates to run on a fake a lake, if you blip the throttle it will die.
I talked to my mechanic and he said its not uncommon for the black scorpion to do this. Poor design in the fuel system thats why the booster is there. Also i believe that booster pump is in the neighbor hood of $300-400.

Where are you located? I have a fuel pressure tester if you need to borrow one.
Old    Jonathan Howell (nu2dagam)      Join Date: May 2004       06-02-2008, 12:06 PM Reply   
Thanks Nate. I put a fuel pressure gauge on it to determine the problem in the beginning.I had initially thought is was the fuel pressure regulator and changed it. Well obvioulsly that was bad too. I put a new fuel pressure regulator on it and it ran good the first time out. Second time out, it worked good for a minute, but then started surging again. I took it to a mechaninc who ran the codes on it and the computer did not throw any codes. So I hooked a fuel pressure gauge up to it and the pressure was dropping from 38 to 20 and the high pressure pump was whining. So I am assuming the high pressure pump is either overheating (it was hot to the touch) or has a restriction in there somewhere. I hope it is the problem and not money wasted. I have changed all the filters. I am going to look at the low pressure carter pump to ensure there is not a blockage in there. I will look for the little filter you described and see if I can find it. That is on the agenda tonight before I stick that expensive pump in it. I even emptied all the gas out and put new gas in it. It is tough without an Indmar dealer to tell me the problem.
Old    Nate (norcalmalibu)      Join Date: Jun 2004       06-02-2008, 1:27 PM Reply   
Jonathan, I was told the fuel filter outside the tank is very small and easy to miss. I have attached a link of Fuel Filters I believe its part#18-7869

http://www.iboats.com/Mercruiser_Fuel_Filters/dm/category_id.268712--view_id.268966

But from the sounds of it I would guess your high pressure pump is dead.

I'm assuming you replaced the fuel/water separator?
Old    Jonathan Howell (nu2dagam)      Join Date: May 2004       06-02-2008, 1:37 PM Reply   
Yeah, I replaced the fuel/water separator. I will look for that filter tonight. And I am going to take off the carter pump and hopefully the high pressure pump and see if I can find any clogs. If so, it will be a spare part for the boat.
Old    Jonathan Howell (nu2dagam)      Join Date: May 2004       06-02-2008, 1:39 PM Reply   
I have actually never seen that fuel filter before. I will definitely look. Thanks again. Hopefully I will have an update tomorrow. I am not expecting a good prognosis, but we will see.
Old    Nate (norcalmalibu)      Join Date: Jun 2004       06-02-2008, 3:13 PM Reply   
Does your system have a feed/return style fuel system? Make sure to follow the feed line all the way to the tank.
Old    Jonathan Howell (nu2dagam)      Join Date: May 2004       06-03-2008, 6:18 AM Reply   
I didnt find the extra filter we were looking for. I did find a screen in the high pressure pump, but it looks ok. I am not going to take it off till the new pump comes in with the directions. I didnt get a chance to go through the carter either. Are there screens elsewhere that anyone knows of?

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:42 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us