Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 09, 2008

Share 
Reply
 
Thread Tools Display Modes
Old    Michael Israel (izzy)      Join Date: Apr 2007       04-07-2008, 12:40 PM Reply   
I used my new Uber Pump(First time I ever used any ballast system)...It filled fine but when I went to drain water (lots) was coming out the side of the pump. Is this normal? If not what can I do to fix it? Thanks for the help!
Old    Montgomery (lovin_the_wake)      Join Date: Jul 2007       04-07-2008, 12:51 PM Reply   
OK I had this exact same problem with mine and all I did to fix it was use RTV silicone around the parts that goes into the sac and around the part that "seals" the pump
Old    Josh B (joshugan)      Join Date: Apr 2005       04-07-2008, 12:56 PM Reply   
I had this same exact problem with every one of the many warrantied pumps I got from them. Simply, it's a horrible design that quickly breaks. See if you can get it warrantied and then get a different brand.
Old    Michael Israel (izzy)      Join Date: Apr 2007       04-07-2008, 1:10 PM Reply   
I was thinking about the RTV idea, I figured it would work but was not sure if it would mess it up. Thank you!
Old    Kevin Hoye (wakebrdr38)      Join Date: Sep 2006       04-07-2008, 1:59 PM Reply   
it comes with an o ring you have to put on the inside
Old    Michael Israel (izzy)      Join Date: Apr 2007       04-07-2008, 2:08 PM Reply   
The O ring is there...it was just a really loose fit.
Old    Dan Duer (libertylake)      Join Date: Jul 2007       04-07-2008, 3:10 PM Reply   
Yep, Silicone worked for me. I actually called Straight Line and silicone was their suggested solution. Hasn't leaked since.
Old    Montgomery (lovin_the_wake)      Join Date: Jul 2007       04-07-2008, 3:14 PM Reply   
Dan, I'm pretty sure you're the one who told me a while back to use the silicone
Old    Dan Duer (libertylake)      Join Date: Jul 2007       04-07-2008, 4:00 PM Reply   
Montgomery...glad it worked then..
Old    Matt (loudsubz)      Join Date: Aug 2001       04-07-2008, 4:00 PM Reply   
can you buy just the adapter for it?

I have been looking all over for it.
Old    Montgomery (lovin_the_wake)      Join Date: Jul 2007       04-07-2008, 5:08 PM Reply   
Dan, It definitely worked and thanks :-)
Matt, You might check buywake.com

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 3:54 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us