Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 09, 2008

Share 
Reply
 
Thread Tools Display Modes
Old    Buzz (buzz_grande)      Join Date: Mar 2004       03-27-2008, 1:09 PM Reply   
I know this is opening up a big ball of wax, but I am looking for suggestions/opinions.

I currently have Rubicon 450's on my tower, and 4 MB Quart speakers inside my boat, Eclipse 12" sub. Right now I have a Zapco 750.2 running the tower, and am splitting the Zapco 1000.4 to run my boat speakers, and the other half for my sub.

What I want to do is get a good class D amp dedecated to the sub, move the 1000.4 to the tower speakers, and the 750.2 for the boat speakers. I feel this will be better all the way around.

I would like to just get another Zapco, but I know there are a bunch of other good sub amps out there. I am not as picky on a sub amp as I am on the tower and boat speakers. I know whatver I add will be an improvement with switching the amps over, etc. I am VERY happy with the way it sounds right now. Just think it would be better with a dedicated sub amp.

Let me know what you think.
Old    "G" (grant_west)      Join Date: Jun 2005       03-27-2008, 1:14 PM Reply   
Do you have your sub's picked out. Nates set up 2 Boston SPG 555's and 1 JL audio 100/1
Old    Big Nate (thesack)      Join Date: Mar 2008       03-27-2008, 1:52 PM Reply   
MTX TA 81001, great amp. Have it in my boat powering 2 Alpine Type R 15's.

But if you like the Zapco amps stay with them. Cuz if you end up not liking the new sub amp and you switch brands you will just kick yourself in the butt for not going with what you already like.
Old    Buzz (buzz_grande)      Join Date: Mar 2004       03-27-2008, 2:34 PM Reply   
Grant,

Yes, I have been running an Eclipse 12" off my Zapco. I have the amp split between my sub, and my 4 boat speakers. Just want to have an amp dedicated to the sub.
Old    Adam Curtis (acurtis_ttu)      Join Date: May 2004       03-27-2008, 3:32 PM Reply   
I've beeen really pleased with my mmats amp. Good power,and the amp barely gets warm ( big issue for me in Houston). Even my "super effecient" alpine PDX amps get hot. I continue to say for the money new or used the JL 1000/1 is overrated.
Old    Nate (norcalmalibu)      Join Date: Jun 2004       03-27-2008, 4:55 PM Reply   
After owning Zapco amps I don't think I will ever purchase them again due to how hot they get. I feel one day they are going to catch fire and burn my boat down.

As for Subs my 2 SPG555s absolutely pound my boat needs dynomat!

So far my JL amp has worked flawless and never gets hot. I wish they had a large 4 channel amp for tower speakers.
Old    Adam Curtis (acurtis_ttu)      Join Date: May 2004       03-28-2008, 6:44 AM Reply   
^^^Nate, my JL amps woudl always get warm to very warm...my matts amp you can't even tell it's on ( by feeling for temp)unless your looking for the power light telling you it's on. I've never owned an amp like this one.
Old    Clubmyke (clubmyke)      Join Date: Aug 2004       03-28-2008, 9:20 AM Reply   
for sub amps - i give the nod to jl audio. as much as i really like zapco's, the jl class d gear is awesome. it will work well with your setup..



(Message edited by clubmyke on March 28, 2008)
Old    Nate (norcalmalibu)      Join Date: Jun 2004       03-28-2008, 9:30 AM Reply   
Adam, I just sold my MMATS sub amp. It never got hot as you described but not enough juice and the only tuning ability was frequency and gain.
I was having some phase problems with my boats and needed more adjustments.

Also I don't know if you have felt a zapco amp but last year I put my arm on one and it burned the skin.
Old    Adam Curtis (acurtis_ttu)      Join Date: May 2004       03-28-2008, 10:59 AM Reply   
Nate, yes they are simple amps ( adjusment wise) but I felt the power was as rated. But you have to run them seeing a 1ohm load. Any other way is a waste.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:24 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us