Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through March 24, 2008

Share 
Reply
 
Thread Tools Display Modes
Old    Nate (mammoth)      Join Date: Apr 2005       03-05-2008, 10:56 AM Reply   
So...we pulled the boat out from her slip last weekend for a good season prep, and I've got a problem with my perfect pass.

The display will come on, but is barely visible and only for a few seconds (like a calculator or watch with a dying battery). If I wait a few minutes and turn it on again, same result.

Anyone seen this on their PP before? I'm wondering if I've lost the power lead to the unit and it's barely running on some kind of internal batt meant for the memory?

The PP was an aftermarket install by the dealer, and I also have a sub under the console that may have vibrated something loose.

Any opinions or pointers are appreciated.
Old    Zach (zacharoo)      Join Date: Nov 2005       03-05-2008, 11:11 AM Reply   
Call PP direct. They have fantastic customer tech guys and they will surely help you out.
Old    AtTheLake (bmartin)      Join Date: Jan 2007       03-05-2008, 11:32 AM Reply   
Check your voltage....PP will fade out and beep if there is not enough voltage to the unit. Mine would do this at idle on my old boat when I had all my pumps and stereo going.
Old    Nate (mammoth)      Join Date: Apr 2005       03-05-2008, 11:54 AM Reply   
Thanks for the info, and please keep it coming.

I'm hoping to get a chance to do some voltage checks later today. I have not had any issues with voltage and the PP during operations. Everything else worked, including both amps. I'm still suspecting a problem with power to the PP unit itself, not a systematic power problem.
Old    Heeb (heeb_v215)      Join Date: Feb 2007       03-05-2008, 9:30 PM Reply   
Check battery voltage first

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 9:06 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us