Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through March 24, 2008

Share 
Reply
 
Thread Tools Display Modes
Old    Who Cares (liljohn)      Join Date: May 2007       03-21-2008, 10:58 AM Reply   
for you guys who are using them how do you like it so far? sound quality? ease of use? etc. i just herd and used one the other day and was a little disapointed. seems like you will have to always be adjusting it. in thought or coments?
Old    Craig Glass (my_malibu)      Join Date: Feb 2008       03-21-2008, 11:09 AM Reply   
what did you not like it's just a eq
Old    Who Cares (liljohn)      Join Date: May 2007       03-21-2008, 11:32 AM Reply   
the sub definatly does not sound good and the mic works but to what extant is another story. when i changed types of music i had to tweek it every time. aka babysitting it.. definatly not what i want to be doing. maybe i need to spend some more time adjusting?
Old    Mikeski (mikeski)      Join Date: Aug 2003       03-21-2008, 3:12 PM Reply   
It's just like two EQ's. I bought one so I could tune my tower seperately than my boat. I frequently adjust mine present EQ setup when I transition from the boat speaks (ie at the marina during lunch) and the tower speaks (when a rider is at the end of the line). The WS-420 should eliminate the need for these changes so I would suggest it need significantly less adjustment than a standard EQ.

If you were tuning the boat on the water, that is a different story. If you dedicate a half day or so on the water to stereo tuning, you can get it done. If you try to do it on the fly it's a challenge.

Just like anything else (computer, new flat screen TV, etc.) it takes a little time to get it set up but you get out of it what you put into it.

my $0.02
Old    Phatboypimp (phatboypimp)      Join Date: Apr 2005       03-21-2008, 4:44 PM Reply   
I think Mikeski is overcharging for his advice.....lol
Old    Craig Glass (my_malibu)      Join Date: Feb 2008       03-21-2008, 8:55 PM Reply   
john what are you running for speakers and amps
remember when running a active eq turn off the amp crossovers
Old    Larry (larrys)      Join Date: Jun 2005       03-21-2008, 10:37 PM Reply   
Why would you turn off the amp crossovers??? The WS-420 does not have built in crossovers.

I just installed mine last weekend and it sounds amazing compared the factory 08 Malibu headunit with out it.
Old    Craig Glass (my_malibu)      Join Date: Feb 2008       03-22-2008, 10:30 AM Reply   
because you should already have passive ones at all the speakers but this means you have to upgraded the stock speakers which you should have done anyway
Old    Tim White (wetsounds1)      Join Date: Jan 2006       03-22-2008, 11:31 AM Reply   
liljohn,

Please try to explain what you mean a bit more as what you wrote is vague. Or email me and maybe I can do a step by step for you on your overall system set up.

Remember that the sub is a bass boost and freq adjustment. So the ring is the freq adjustment and the center knob is a bass boost. So most likely that was up to high as it does 30HZ to 300HZ. That should be more in the 60HZ to 80HZ depending on the woofer etc... The in boat volume controls the vol of the boat and the sub.

You should set it like what Mikeski is refering to and not have to mess with it. It is 2 EQ's in one. So you EQ the towers and leave it. Then EQ the in boats and sub and leave it. Once my system and EQ is set. I never, ever mess with them. As I have just spent hours getting the system dialed in. I do not want to re do everything.

The only thing you will want to do is the volumes. But if your system is set up correctly. And you dial in the towers and dial in the boats. You should really never have to mess with the EQ. Or the Sub freq.

So really the only thing is to maybe turn the sub boost up or down and the vol.

I do not see why you would ever have to adjsut the EQ's. Ever. An EQ is used to set the system. It is not used to constantly tweak.

It sounds like you did not have the rest of the system set up properly. The line driver voltage on the ws420 has gains on it as well. Those need to be adjusted. You may have been over driving the input signal. So you were having to mess with the adjustments to get it to sound right.

Email me and I will help you get it sounding right.

Tim
Wet Sounds
Old    Cody sizzle (cody_08_lsv)      Join Date: Feb 2008       03-22-2008, 3:45 PM Reply   
I totally agree once everything is set only the volume and sub volume should be used .... I have the 420 on my bu and im n love with it
Old    Who Cares (liljohn)      Join Date: May 2007       03-22-2008, 7:07 PM Reply   
ok premature freek out. with a few hrs of twist this and tweek that the system now sounds absolutly awsome.I just needed to take some time and adjust the gains. thanks for all the advise. Tim your the man this thing rocks.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:17 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us