Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through October 28, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    motobob13 (motobob13)      Join Date: Jun 2006       10-21-2007, 6:20 PM Reply   
I have a 2003 Centurion Cyclone with 3 stock hard tanks. It uses 3 Mayfair Cartridge style pumps. These are the yellow ones with the black tops.
When I try to fill the tanks the pumps turn but do not flow any water. If I crack the top of the pump open they spill water out of the top and when the top is snapped back on they pump fine. Emptying the tanks works fine. Any ideas what may be up with these?? Thanks -Bob
Old    George Aslinger (mobv)      Join Date: Jun 2002       10-21-2007, 7:47 PM Reply   
They are getting air locked. I believe the intakes are under the platform in 2003. Try backing the boat up to force water in. Others have said that the engine must be off because the exhaust puts air into the pump intake. I never had that problem with my 2004 with that same configuration.
Old    Kevin R Baugh (krbaugh)      Join Date: Mar 2002       10-21-2007, 7:53 PM Reply   
What he said
Old    Patrick Steed (steedracer)      Join Date: Jul 2007       10-21-2007, 7:58 PM Reply   
My rear port side pump sometimes is air locked at start up. If I reach down and lift and/or jiggle the intake hose a bit, it will then "load" with water and begin pumping. I normally fill my fat sacs with the engine off. Interestingly, with the engine running, the starboard side picks up too much air from the exhaust, while the port side doesn't. Since it would take the starboard side longer to fill with the air getting in, I turn the engine off while filling.
Old    Show (bigshow)      Join Date: Feb 2005       10-21-2007, 8:38 PM Reply   
I agree with Patrick. The exhaust ports are near the fill ports on my Lightning. I never fill with the engine on. Like Patrick it took a knock to get one of them going this last season. I did replace the cartridge on one pump thus year.

Cartridges are pretty cheap and very easy to replace.
Old    Swatguy (xstarrider)      Join Date: Jun 2007       10-22-2007, 8:27 AM Reply   
Agree with all. What I used to do was slam the boat in reverse turn off ignition and flip the switch. Never a problem unless I was on a river with a strong current. In that case I reversed the boat into the current and then did the same. It's a pretty common problem with these pumps due to their location, so don't worry too much. Also try cleaning the rubber seal around the top and put some vasaline on it SMALL AMOUNT to seal it a little better.
Old    motobob13 (motobob13)      Join Date: Jun 2006       10-22-2007, 4:16 PM Reply   
WOW thanks for all the quick responses. I tried the "slam it in reverse" method this afternoon and got 2 of the 3 pumps to prime. I will lube the seals tonight and see if that helps. Anyone have more of a permanent solution besides the jiggle, knock, and slam methods? (sorry yankees but the lake was 82 today and f-l-a-t).
Old    antifan (mars)      Join Date: Aug 2005       10-23-2007, 12:38 AM Reply   
Assuming your impeller is starting up and spinning normally when switched on (if not you need a new impeller) I agree that it sounds like an airbound impeller. Also assume you know not to fill it while idling/engine running.
Last tip is to unscrew the screen "mushrooms" under the swim platform and make sure there is no debris/obstruction in the pump inlet.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:43 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us