Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through October 28, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    spencer heywood (spenchey)      Join Date: Dec 2006       10-02-2007, 11:14 AM Reply   
Just wanting to hear what everyone thinks of this boat.
Old    Ewing (johnsvt)      Join Date: Dec 2006       10-02-2007, 11:36 AM Reply   
Really not out yet dealers have just placed their orders. Tige is making a very nice product easily as nice as the big three(MC,CC,or Malibu.) They just need to ban that no ballast campaign.
Old    Ryan Lacefield (26lacefield)      Join Date: Aug 2006       10-02-2007, 1:08 PM Reply   
yeah i would love to see ballast come on all the boats. atleast the v-drive. they would get sooooo much more credit from a lot more people if that happened. but i know it would take a lot talking to the designers about it. anyone that says the 08's aren't as nice as the big 3 is crazy. all i can say to them is go demo an 08.
Old    Sugadance (mr_nuggieborn)      Join Date: Sep 2007       10-02-2007, 3:25 PM Reply   
its the Gentle Men's choice!!!
Old    Kscales (kscales)      Join Date: Oct 2006       10-02-2007, 4:32 PM Reply   
I have a 08 RZ2 with factory Ballast. It was a option just like anything else on the boat. On my 07 22Ve I did not opt for it, this time around I did. It's nice to have the choice to suite your needs.

I think people are still under the impression that Tige doesn't offer any ballast, maybe true years ago but not now. Every Tige boat since 2006 ( I believe?) have had the factory option of either 600LB or 900LBS of internal ballast.
Old    Ryan Lacefield (26lacefield)      Join Date: Aug 2006       10-02-2007, 7:22 PM Reply   
kscales are u only running the 900 pounds in your boat. if you are u should try 1300 up front and 1400 in the back. my 07 RZ2 throws a sick wake with that weight placement.
Old    Kscales (kscales)      Join Date: Oct 2006       10-02-2007, 7:59 PM Reply   
Hi Ryan,

Are you talking about additional weight over the stock ballast or total weigh including the stock ballast?

I have 2 Vdrive fat sacs and I also have a intergrated bow sack left over from the last boat that I can thow in on top of the stock ballast.

Let me know your complete setup so i can try it.
Old    Ryan Lacefield (26lacefield)      Join Date: Aug 2006       10-02-2007, 10:16 PM Reply   
i'm talking about combined weight. i use a lot of lead in my set up. in the rear i have to factory tanks(500lbs), in each rear storage a tube sac thats plumed into the ballast switches(370 each-740 together) and then 200lbs of lead. in the front i run the factory soft sack under the seats(400lbs) and then just got a bunch of old lead tire weights for the rest of the front weight. i wouldn't say to leave the lead up front when towing unless you have a bigger truck like an F-250 or above like mine. it might be too much tounge weight for F-150's or 1500's.
Old    LT (running_turtle)      Join Date: Jun 2007       10-03-2007, 1:18 PM Reply   
i rode behind a 07/08 RZ2 (i dont know ) but we had it stacked with 2 750+lb sacks going down the middle and i he said 500 on each locker, and a Fat Brick in the corner 155lb, there may have been more hidden away somewhere
Oh no factory ballast
Wake was freaking sick tho
Old    Grady (stresn)      Join Date: Oct 2004       10-05-2007, 12:13 PM Reply   
Hey Ryan, - Grady from Oregon....are you running the 400 in your RZ?
Old    Ryan Lacefield (26lacefield)      Join Date: Aug 2006       10-05-2007, 12:27 PM Reply   
Hey Grady are u talking motor. if you are i'm running the 340 with the power prop(acme14.50-14.25) if your going to run 1800+lbs i would def get the power prop. its gets the boat up n going like your not running any weight in it.
Old    Grady (stresn)      Join Date: Oct 2004       10-05-2007, 1:32 PM Reply   
I was running the 340 with 1200 and having a little problems in our private lake fully loaded....you don't have any issues with the up and go with 1800....
Old    Ryan Lacefield (26lacefield)      Join Date: Aug 2006       10-05-2007, 2:16 PM Reply   
no i don't have any problems. my boat has 2600lbs in it. what elevation are u at. i'm at 300 feet. when i'm at a lake thats at about 2,000 feet elevation i can only run about 1000lbs or it will just take forever to get going.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:06 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us