Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through September 10, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Patrick F (lakepirate)      Join Date: May 2007       09-04-2007, 4:44 PM Reply   
I took my boat to beautiful Lake Mead this weekend. The trip and the lake itself were awesome, BUT, I found that the launch ramp we used at one of the marinas was really flat and therefore, had to damn near sink my truck to load/unload. I'd say the water about a quarter up my FRONT tire. So today, I took my truck for a spin and heard what seemed to be an odd sound coming from the motor. Is it possible that going that deep caused a problem to the motor? The truck is running completely normal, just some new sounds. I assume I'd know if something was really wrong, but wasn't sure. Anyone had problems or know about problems with engine/truck damage from loading too deep?
Old    Peter_C (peter_c)      Join Date: Sep 2001       09-04-2007, 5:40 PM Reply   
You are more likely to damage bearings, brakes, etc., long before an engine. 1/4 the way up the tire is nothing, but the rear end was probably submerged. Better check to see how high your rear axle vent goes, and it might be a good idea to change some fluids again depending on how deep you went.
Old    Trace (trace)      Join Date: Feb 2002       09-04-2007, 7:12 PM Reply   
You probably sucked water through the vent in the rear end. If you submerge the rearend, which is hot from towing, it is cooled very quickly by being submerged in the lake. The air inside contracts when it cools, so if the vent is submerged it will suck in water. As long as you haven't driven it too far, change the fluid a couple times and you'll be fine.
Old    Army Dad (sam8)      Join Date: Dec 2004       09-04-2007, 7:58 PM Reply   
Bearings, brakes etc is where I would look.
Even U-joints. Change the lube in the rear axle for sure.
If your front brakes are disc, and the rotors were hot when you backed into the water they very possibly warped, but you should feel the oscillation in the brake pedal if that happened.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:32 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us