Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through September 10, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Brent (icedog10)      Join Date: Sep 2007       09-04-2007, 8:06 AM Reply   
I have been thinking about getting Perfect Pass for my 93 Prostar 205. The lake I am on has lots of weeds and I loose the speedometer quite often and have to drive by RPMs. How does Perfect Pass address this issue?
Old    Ian Brown (wakereviews)      Join Date: Sep 2006       09-04-2007, 8:48 AM Reply   
check zero off, that might be an optimal fix for you.
Old    Trace (trace)      Join Date: Feb 2002       09-04-2007, 12:20 PM Reply   
Only - I don't understand your response?

Paddlewheel speed sensors (as opposed to pitots like your speedos use), are almost impervious to weeds. We have a lot ofg hydrilla in one of the lakes around here, and it clogs my regular speedo all the time, but PP has never had any problems reading speed.
Old    Ian Brown (wakereviews)      Join Date: Sep 2006       09-04-2007, 12:23 PM Reply   
only made the comment b/c since zero off doesn't rely on any on water speed sensors it would be impervious to any debris in the water. Sorry, have no personal experience with PP in water with a lot of growth.
Old    Phil Jakubowski (65sanford)      Join Date: Feb 2007       09-04-2007, 12:46 PM Reply   
We also have alot of weeds and have no issues with perfect pass working
Old    Trace (trace)      Join Date: Feb 2002       09-04-2007, 3:34 PM Reply   
What is "zero off"? A different speed controller mfr?

Too bad nobody has come out with a weedless prop yet.
Old    Trace (trace)      Join Date: Feb 2002       09-04-2007, 3:38 PM Reply   
Nevermind... http://www.zerogps.com/
Old    Sinko (sinkoumn)      Join Date: Jan 2007       09-04-2007, 4:13 PM Reply   
Uhh , Zero off won't work on pre 07 or 08 boats doggie

(Message edited by Sinkoumn on September 04, 2007)
Old    Ian Brown (wakereviews)      Join Date: Sep 2006       09-04-2007, 4:36 PM Reply   
need drive by wire? didn't realize that if so :-(
Old    Sinko (sinkoumn)      Join Date: Jan 2007       09-04-2007, 4:42 PM Reply   
thread jack, Trace your profile pic is SICK!

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 3:33 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us