Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through September 10, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Greg Bodor (gti2lo)      Join Date: Nov 2005       08-20-2007, 10:21 PM Reply   
So I have myself a 06 X-1 and it doesn't have tower speakers.

I have just bought a pair of fusion speakers, amp, etc.

I am looking to installing them on the weekend.

How do I wire these up? (don't think it's that hard)

Do I run the speaker cable up through the tower where the existing navigation light wires are run? (starboard) or do I run it up starboard side (where amps are going to be)

Furthermore are there any tips to pulling the wire through other then doing section my section with the tower folded, etc?

I am assuming the top section of the tower will be the hardest due to the curve of the piping.

Thanks in advance

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 3:16 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us