Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through August 06, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Dan Duer (libertylake)      Join Date: Jul 2007       08-03-2007, 8:39 AM Reply   
My Ubber pump leaks horribly when I drain. Only used it twice to drain. The seal/o-ring seems fine. Any suggestions? Used the Tsunami and no leaks.
Old    Trapper (canucked)      Join Date: Jun 2007       08-03-2007, 8:56 AM Reply   
mine leaks to, I was going to take it back but haven't got around to it.
Old    Dan Duer (libertylake)      Join Date: Jul 2007       08-03-2007, 1:50 PM Reply   
I called Straight Line, they said to put silicon sealer around the 0-ring. Anyone tried this.
Old    Montgomery (lovin_the_wake)      Join Date: Jul 2007       08-03-2007, 2:06 PM Reply   
Mine leaks like Fing crazy when I drain it seems like half the water ends up in my boat

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:41 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us