Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 11, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Jason Budnik (jbudnik)      Join Date: Oct 2006       07-05-2007, 10:56 PM Reply   
Anyone have problems with their swivel racks on the 07 boats? Mine keep breaking and swinging on there own. I have just been putting a cable around them. May as well be solid mount.
Old    www.midwestwakeboarder.com (gmarkham1)      Join Date: Sep 2003       07-06-2007, 5:24 AM Reply   
I had this problem with my '06, what a nightmare...

the one rack did swing in once on the '07, but only once.. led me to beleive that it wasnt swung out all the way.
Old    DRA-its Lifestyle (deltariderscom)      Join Date: May 2007       07-06-2007, 7:05 AM Reply   
Jason;

If your concerned in the racks swinging and don't want a cable around them there is a locking pin on the underside of the rack mount that you can lock it closed. Roswell thought they had this problem fixed, might just be a isolated incident but definitely one they will fix.

(Message edited by deltariderscom on July 06, 2007)
Old    Jeff Newton (jnewton7)      Join Date: Jun 2005       07-06-2007, 7:27 AM Reply   
I have the same problem on my 07 21v....they would hold ok except for when you were in rough water or on double ups...then they would swing in....I just use the manual locking pin.
Old    ATX_Supra_SSV (atx_supra_ssv)      Join Date: Jul 2007       07-06-2007, 7:43 AM Reply   
I have not had any issues on my 07 22SSV. I would think it would be a quick warranty fix though. What has your dealer said?
Old    21VRobert T (robert_t)      Join Date: Feb 2005       07-06-2007, 9:07 AM Reply   
I updated to the 07 racks on my 05 21V have no problems at all.
Old    Mike Arndt (24_ssv)      Join Date: Mar 2007       07-06-2007, 9:31 AM Reply   
I upgraded from the 06 racks to the 07's and have not had any problems since.
Old    kenton irvine (wave63)      Join Date: Jan 2007       07-06-2007, 3:59 PM Reply   
I have found that the pin will stick from air water wd40 works well fixed mine.
Old    Adam Curtis (acurtis_ttu)      Join Date: May 2004       07-06-2007, 5:47 PM Reply   
had the same issue on my 07 SSV, and got the problem fixed under warranty with a new set
Old    Diggs (pdxWAKE) (tyler97217)      Join Date: Aug 2004       07-06-2007, 9:25 PM Reply   
i think it was the early 07 models that had some issues... check your hull number and if it is an early number it seems that those tended to be the ones with a few issues... roswell is warranting them out.....
Old    Jason Budnik (jbudnik)      Join Date: Oct 2006       07-07-2007, 12:38 AM Reply   
I had them warrantied when I got the boat in October last year. I see though that other people had the same problem. I hope they get a better fix than that single button. I think it is the same they just made a bracket to push all the buttons at the same time.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 1:12 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us