Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through April 09, 2007

Share 
Reply
 
Thread Tools Display Modes
Old    Chad Wheeler (malibu73)      Join Date: Jun 2006       03-26-2007, 5:49 PM Reply   
I have a 95 Moomba boomerang direct drive and it will run fine when pulling or going faster than idle, but when I slow down and stay at idle for a long time (no wake zones) the engine starts to run rough. To get it to run better, I have to lift the hatch and let the engine breath. After that it will run fine untill it gets stuffed up again. Any ideas on fixing this? I have 3 vents in the back, but only one is blowing anything. Would buying another in-line blower and adding it to the back help or would that take to much air from the engine compartment?
Old    Art (rallyart)      Join Date: Nov 2006       03-26-2007, 6:45 PM Reply   
Your carb is starting to percolate, probably. The cause could be the float is sinking so it does this easier. That fix is rebuilding or replacing the carb. The cause could be a lack of ventilation and another blower would help but before you spend those dollars check the air intakes. If you've done any interior work they could have been blocked or maybe full of leaves, or anything.
cold air at the fuel pump if it's on the block, the carb, and into the compartment will fix it more easily than drawing out air with a fan.

If it's percolating it will run rough and may stumble when you try to get on throttle.

It could also be the condensor, or coil, or lots of other stuff...
Old    Chad Wheeler (malibu73)      Join Date: Jun 2006       03-26-2007, 7:41 PM Reply   
How would I get cold air to the fuel pump? Put a blower reversed sucking in air at the front vents?

I just replaced the coil, spark plugs, distributor cap, and had the carburator rebuilt. Like I said, it only happens at idle and it stops a couple of seconds after I open the lid.
Old    Art (rallyart)      Join Date: Nov 2006       03-26-2007, 8:21 PM Reply   
It's definitely heat in the engine compartment then. The two grills on the bow of your Moomba are probably the intake air points. (I'm not familiar with your boat. I just looked at the picture on your profile.)
From each of those there should be a large 3" or 4" line that runs down to the floor and into the engine compartment. If those lines are not there, or are blocked, you won't be getting cold air in. If they are and they're open you should be getting lots of air in and you've got to check the exits. You said there are three. Check that each is open and not blocked by upolstery, sacks, or anything. There might be large lines going to the exits similar to the intakes.
If you need to extend one of the lines to blow up at the fuel areas of the engine.
If all else fails you can get a heatshield carb plate or an insulator gasket for under the carb from a speed shop.

When you are moving the vents should move much more air than any blower can.

(Message edited by rallyart on March 26, 2007)
Old    Chad Wheeler (malibu73)      Join Date: Jun 2006       04-08-2007, 7:23 AM Reply   
I looked in the back at my blower, there are three vents in the back but only one, the one that has been blowing, has a tube hooked to it. I never found where that line went to or if it was clogged. I guess I'm going to start and check the lines and see if there is any blockage and go from there.
Old    George Aslinger (mobv)      Join Date: Jun 2002       04-08-2007, 8:08 AM Reply   
If you had all that work done in addition to checking the compartment air intake I would check the spark arrestor (air breather on top of the carb) and make sure tehe carb idle air adjustment is correct. If this only started after setting awhile and following all of that work you should be able to correct without any additonal parts.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 8:21 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us