Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through December 20, 2006

Share 
Reply
 
Thread Tools Display Modes
Old    Nick (ndavis03)      Join Date: Jul 2006       11-29-2006, 2:48 PM Reply   
I am thinking about buying a pair of wetsounds pro80s, but need amp advice. I already have a kicker kx350.4 and wanted to know if anyone else has used this amp to push a pair of pro80s. The specs on the kx350.4 state that it runs 175 RMS to 2 channels in bridged mode, and that bridged mode is 4 ohm stable. Would I be limiting the pro80s. Any advice will help.
Old    Fro-Z (froese)      Join Date: Jun 2005       11-29-2006, 3:57 PM Reply   
1st, the speakers are incredible. Love mine. I'm running them off of an Infinity 7541a amp. 278wRMS power x 2. I think you're gonna want more power than the kx350.4 (keeping in mind that the Pro80's are rated at 175watts RMS). These speakers suck up the juice, and with good reason - they're loud and constant with their power needs.

Wetsounds recommended to me that I get an amp that is rated for more power than the speakers are rated. This keeps my amp from over heating and kicking off (I have a separate sub issue which should be solved by a capacitor). This doesn't mean you don't have to be careful with how loud you crank them up - over power them too much, and they'll blow like any other speaker.

Anyway, I'm happy with the 280watts (that IS rms) I'm pumping into mine.

pics at: http://www.2froeses.com/sn2001 (scroll to the bottom of the page)
Old    Mikeski (mikeski)      Join Date: Aug 2003       11-29-2006, 4:38 PM Reply   
This is what I push my Pro-485s with, works great for 100 hours now.

http://www.woofersetc.com/index.cfm?fuseaction=product.display&product_id=12 0

Make sure all your amps are installed in either a chimny arrangement where natural convection will push the heat out an pull cool air in or at least flat with the label up. Upside down and sidways will cause amps to overheat.

It's 2 X 400W, cross it over at 200hz, they will scream.
Old    Jon Allen (jon_a)      Join Date: Feb 2003       11-29-2006, 4:40 PM Reply   
I installed a pair of Pro80s today. I have them running off of 2 channels on a 4 channel 740 watt Kenwood Amp. They are screaming!!!!!
Old    JTW (sangerlover)      Join Date: Sep 2005       11-30-2006, 6:28 AM Reply   
I have a Memphis 500.4 feeding (2) pro 80s and (1) 485 and seems to be plenty of power.
Old    Nick (ndavis03)      Join Date: Jul 2006       11-30-2006, 1:41 PM Reply   
Jon Allen-do you know what model Kenwood amp you are running?
Old    Jon Allen (jon_a)      Join Date: Feb 2003       11-30-2006, 1:54 PM Reply   
I used a Kenwood KAC-X452. It is the standard 4 channel amp that is coming in the Supras and Moombas.
Old    David (tparider)      Join Date: Aug 2003       11-30-2006, 2:21 PM Reply   
I'm running 4 Pro-80s off a Massive Audio 800.4. These speakers really are unbelievable.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 5:32 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us