Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 21, 2006

Share 
Reply
 
Thread Tools Display Modes
Old    Clayton191 (clayton191)      Join Date: Apr 2006       07-12-2006, 5:50 PM Reply   
I came home from a five day business affair only to find that we had recieved TONS of rain. The boat wasnt covered by anything other than the normal cover that USUALLY does an amazing job of keeping water out of the boat.

I hopped in and started vacuuming up the extra water that had manged to seep through the cover - and I began to think "wow, this is a lot more than usual" ...

I instinctivly open up the back pad of the engine compartment to find it nearly 2/3rds full of water. It looked like the oil pan was sitting in water - but I dont know if oil got in it. Has anyone had this happen? Does anyone know the standard procedures to look things like this over for damage?!?! I'm about to vomit. I've had the worst luck with this boat so far...

Am I going to have rusting on any of the engine compartment parts? I'm still draining it via bilge as we speak....

How can I tell if water got into the oil?
Old    Danny (boomerang)      Join Date: Feb 2006       07-12-2006, 6:01 PM Reply   
Do you not have an auto bilge?

I thought all boats had auto bilge pumps.

I would just change the oil, did it get to any electrical parts?
Old    Clayton191 (clayton191)      Join Date: Apr 2006       07-12-2006, 6:12 PM Reply   
I dont know, my auto bilge didnt work! I've been having it do some wierd things lately (the bilge that is -- ) so I dont know, maybe thats why it didnt get out.... :\
Old    Danny (boomerang)      Join Date: Feb 2006       07-12-2006, 6:18 PM Reply   
That would be the first thing I figured out.
Well after I changed the oil.
Could just be a fuse.
What type of boat is it?
Old    Matt (pittsy)      Join Date: Apr 2004       07-12-2006, 6:19 PM Reply   
you should take the center plug out of the boat when it is out of the water!
Old    Aaron Ware (99_slaunch)      Join Date: Oct 2005       07-12-2006, 6:31 PM Reply   
Change the oil it's cheap. Better safe then sorry. 15-20$ oil change or possible engine damage. Sounds like with you're luck you should NOT take the chance!!!!
Old    Clayton191 (clayton191)      Join Date: Apr 2006       07-12-2006, 7:31 PM Reply   
haha ... For real... So further evaluation leads me to believe that everything will be okay - the oil looks good - but I am going to change it JUST TO BE ON THE SAFE SIDE. Also, looks like none of the electrical stuff was submerged nor was anything other than just "engine block" and piping had water on it. I started thinking that if the engine is sealed, nothing would get into it - so I am not going to have a rusty engine block or anything like that. I took some wd40 and went to town, wiping down everything that was wet. I'm going to get the oil changed tommorrow and see if she starts up and runs. I think it will be fine. My bilge is fixed now I think too - a connector was off of it (must have rattled off) and that could explain some of its odd behaviors the last few days.

Anyone has any other suggestions, i'll take them. Lets hope the rain doesnt come down tonight so I can leave the cover off and let the bad boy dry out....

In other fronts, a hot girl just txt msged me and is wanting to meet up tonight.... maybe I am just getting really lucky AFTER having some bad luck! haha.
Old    Aaron Ware (99_slaunch)      Join Date: Oct 2005       07-12-2006, 7:41 PM Reply   
I don't know she could be a psycho. Hope it works out for you.

Check the transmission fluid to it should be blood red if it is pink then water got in.
Old    Dizzy Jenkins (dizzyj)      Join Date: Jul 2003       07-12-2006, 8:05 PM Reply   
might loose your starter depending on where its located.
Old     (insuranceman)      Join Date: Jun 2005       07-13-2006, 12:36 PM Reply   
Clayton, Did you leave the drain plug in the boat?????????
Old    Peter_C (peter_c)      Join Date: Sep 2001       07-13-2006, 1:33 PM Reply   
Plan on a steering cable

If you are handy and have a decent set of tools you can remove the back part of the steering cable and put a zerk into the cable, then grease the heck out of it. Towing riders will help move the grease around, then pump some more in.
Old    Stan Tanner (sbt3)      Join Date: Jun 2002       07-14-2006, 6:49 AM Reply   
I would agree with dj and Peter, you are probably going to need a new starter. Once they get really wet they usually go bad. The steering cable is probably also toast, but those seem to go every 5 years or so anyway. .

Peter-
Do you have any pics of placing a zerk in a steering cable. I would like to see them. I just replaced mine this spring and would consider putting one in if it would help the life of it.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 12:12 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us