Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through June 21, 2006

Share 
Reply
 
Thread Tools Display Modes
Old    Matt Poirot (chopper515)      Join Date: Mar 2005       06-09-2006, 5:40 AM Reply   
As all Simer users know, they are not run dry protected. Iím usually always well aware of when my pumps are running and I can hear a distinctive sound difference when the sacs are empty. Well yesterday I must have had a few to many and I had the music up and I forgot that my locker sac was draining. About 10 minutes after the sac had drained I realized the switch was still on and I thought for sure I had burned up the pump. My only hope was that it blew the inline 30 amp fuse. Sure enough the fuse was blown, so I swapped fuses with my other pump and it still works! I still need to test it out on the water to make sure the impeller is OK, but at least the pump still runs.

Has anyone had this happen to them? Was the impeller OK?
Old    Trace (trace)      Join Date: Feb 2002       06-09-2006, 6:31 AM Reply   
You may have damaged something a bit, but it will probably still work OK. Mine got down to like 3 blades on the impellers and still got the job done, but slow. You can buy rebuild kits ($10 or so) and complete replacement heads ($25 or so) from BE Atlas.
Old    Matt Poirot (chopper515)      Join Date: Mar 2005       06-09-2006, 10:07 AM Reply   
Trace, is the rebuld kit just an impeller?
Old    Trace (trace)      Join Date: Feb 2002       06-09-2006, 10:31 AM Reply   
It's an impeller, 2 wear plates, cam housing, and O-ring.
Old    D. Cooper (dcooper)      Join Date: Mar 2005       06-09-2006, 11:54 AM Reply   
Call Simer and get the part numbers for the above mentioned and keep them in the boat. Very easy to change. I bought like four of each part to keep on the boat, cost was like $14, from Home Depot.
Old    gp (goinboardn)      Join Date: Feb 2005       06-09-2006, 12:14 PM Reply   
I have done this to my Simer pump on several occasions (oops) and the only thing wrong so far has been the fuse.

(Message edited by goinboardn on June 09, 2006)
Old    Matt Poirot (chopper515)      Join Date: Mar 2005       06-09-2006, 12:25 PM Reply   
Thanks for all the input. D. Cooper, does Home Depot stock these parts?
Old    D. Cooper (dcooper)      Join Date: Mar 2005       06-09-2006, 1:29 PM Reply   
No they just special order them. I had to call for part numbers and they ordered... took about a week but, if you order them from the store and pick them up there are no shipping cost. I am sure BE Atlas can get them to you but, w/ shipping.
Old    Mikeski (mikeski)      Join Date: Aug 2003       06-09-2006, 5:26 PM Reply   
I bought two spare impellers when I installed the second Simer in my old boat, they were still in the package when I sold the boat.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:41 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us