Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 19, 2006

Share 
Reply
 
Thread Tools Display Modes
Old    Diggs (pdxWAKE) (tyler97217)      Join Date: Aug 2004       05-05-2006, 7:28 AM Reply   
On the way in last night I noticed my V-Drive light is staying on over 1000 RPM. It is just locked on. I am going to run it to the dealer for scheduled service anyway, but wanted to see if anyone had any tips on anything to check on.
Old    Zach (zacharoo)      Join Date: Nov 2005       05-05-2006, 7:58 AM Reply   
If the light is on it means that the fluid level is to low for operation. Per the manual, just check the fluid level with the dip-stick and consult the OM for the proper fluid replacement type.
Old    E Double U (three6ty)      Join Date: Feb 2004       05-05-2006, 7:59 AM Reply   
Your V-drive should no tbe leaking oil either. If it is there is a seal that needs replaced. ( $$$)

Old    Trace (trace)      Join Date: Feb 2002       05-05-2006, 8:18 AM Reply   
It is usually just the sending unit that is broken. They aren't very reliable - I've been thru 2 of them now.
Old    Elane (ebone66)      Join Date: Dec 2005       05-05-2006, 8:19 AM Reply   
I probably have the same light as you on my Moomba and the same problem. I called the dealership about it. It stays on in neutral and low RPM's but should go off when you get the boat moving.
Old    discolafinger            05-05-2006, 8:27 AM Reply   
diggs did you check the level
Old    ausbill32            05-05-2006, 8:51 AM Reply   
I just checked my Supra manual. Light will remain on until 1200 RPM. If light remains on after that check V-Drive fluid level. If level is ok, then you have no choice but to go see a dealer.
Old    Diggs (pdxWAKE) (tyler97217)      Join Date: Aug 2004       05-05-2006, 8:52 AM Reply   
Have not checked level yet... was ready to get home last night and hit the sack.... I think I will run it to the dealer tomorrow since it is about ready for service anyway....
Elane
Correct the light should go out once you hit 1000RPM, but mine is not.
Old    SeaDawg (seadawg)      Join Date: Jan 2006       05-05-2006, 5:13 PM Reply   
Unless you are low on fluid, then Trace probably gave you the right answer - a bad sending unit. I went through this at the end of last season, my fluid level was fine so I swapped the unit and it's golden now.

The other thing it could be is a leak in one of your hoses. Dealer can check that for you. Replacing the pressure sensor/sender is less than 40 bucks if you do it yourself, and it's easy.

By the way, if the fluid level is low, fill it up via the dipstick hole with SAE 30.
Old    Sparky Jay (wake_upppp)      Join Date: Nov 2003       05-05-2006, 5:21 PM Reply   
Might wanna check on the type of fluid. My "Walter" V-Drive in my new Sanger takes 80-90w gear lube.
Old    SeaDawg (seadawg)      Join Date: Jan 2006       05-05-2006, 10:03 PM Reply   
<shrug> That's the information I got from the Walter support tech who helped me through my V-Drive issue.
Old    Sparky Jay (wake_upppp)      Join Date: Nov 2003       05-05-2006, 10:09 PM Reply   
Interesting. My info came straight from Sanger, but my owners manual actually states either can be used. Since I was just topping mine off, I wanted to use what was already in there.
Old    Diggs (pdxWAKE) (tyler97217)      Join Date: Aug 2004       05-06-2006, 1:04 PM Reply   
Thanks for everyones help. My dealer came and grabbed it today and will sneak a peak to make sure all is good. Thanks again for everyones help!

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 11:11 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us