Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through July 23, 2005

Share 
Reply
 
Thread Tools Display Modes
Old    Matt Brinner (rmbrinner)      Join Date: Jun 2005       07-23-2005, 1:49 PM Reply   
I just purchased an 02 X-Star with 330 hrs in June. Now it has 345 hrs and problems with the transmission. I took it to the mastercraft dealership in Memphis and gave them a go ahead to pull the transmission out, and they think they might need to send it off the Hearth (I believe) in order to get it rebuilt. They said that it is full of water, and that it is making some awful racketing noises (like something is getting ready to break) when you start to engage the throttle. They said they have never heard this problem before, so they are afraid to just change the seals because that would be 8 or 9 hours of work and still might not fix the problem.

Have any of you heard of this problem before?

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:38 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us