Articles
   
       
       
Pics/Video
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WAKE WORLD HOME
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 04, 2005

Share 
Reply
 
Thread Tools Display Modes
Old    Jay (jayc)      Join Date: Sep 2002       04-22-2005, 2:30 AM Reply   
Pulled the waterpump on my boat last week as it was making some bad noises and the bearing were shot.

This is what i found when it was pulled it


http://www.savepic.com/freepicturehosting/is.php?i=357483&img=waterpump.jpg

Now I don't think that is bad considering that this boat has spent 13 years of its life (16 years old 2500 hrs) in salt water without flushing.

How do I know it spent that long without flushing? Well the boat was my dads. Owned from 6 months old it spent 6 - 9 months of the year moored up in the salt then pulled out and left for the winter. No flushing at all.

I've owned the boat for the past 3 years and I do flush after each use, well normally. If we pull the boat out at 9pm one day and I know we will be back in 9am next day I don't bother.

Its the original waterpump with 2500 hours on it. The rest of the engine (block, heads etc) were replaced with a new long motor 3 years ago when I got it so I know they are all good inside.

Makes me feel better about saltwater if you can abuse something for that long and it still had plenty of material left in the casting. OK the impeller is well shot but the casting is ok!

(Message edited by jayc on April 22, 2005)
Old    zboomer            04-22-2005, 2:18 PM Reply   
Old    Stanfield (stanfield)      Join Date: Mar 2004       04-22-2005, 2:57 PM Reply   
Just attach the photo to this post.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:04 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2012 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us