Wake 101
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through August 27, 2003

Thread Tools Display Modes
Old    oshensurfer            07-24-2003, 9:55 AM Reply   
Well, I read all the posts previously about Centurions and said, "Man, I'm glad I'm not having the problems these guys are having." Well, things have changed and I should have knocked on my teak. I have an '02 Hurricane and have the following issues:

-Ballast failure after ballast failure. Works fine at the dealer where they are not sucking hot exhaust water into it. Service says Fineline agreed to replace the ballast pumps....will call when they come in. Don't think that will solve the problem because the water is sucked in right at the exhaust and above the trim plate.

-Getting a repetetive lull in the tranny at WOT. This one scares me. When I had the 3 blade on there, the RPM's were dancing all over the place (Ex. RPM 3300 at 19MPH), but the lull has happened before the prop was changed out, just not as bad as it was with the 3 blade. It lulled repeatedly and I brought it back to neutral and the engine shut off! Started right back up though. Any advice???

-Had a bent 4 blade prop, got replaced by a 3-blade (thats another story) now there was severe vibration out of the hole and at very slow speeds. Generally, when I would slow down and turn around to pick up a boarder that fell. Worse when at full port or starbard rudder. Replaced it back to a 4-blade. I hope this takes care of the vibration. Service guy said it was prop wash???? Does that sound right??

-Pilot I Thermometer not working

Mainly I'm writing this thread to see if anyone else has had these issues with their Centurion and what they have done to fix them. Not to bash Centurion, since all I've dealt with are Service Departments so far.


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

All times are GMT -7. The time now is 8:05 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home


© 2016 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us