Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through November 04, 2009

Share 
Reply
 
Thread Tools Display Modes
Old     (hugo_salcedo)      Join Date: Mar 2007       10-29-2009, 3:50 PM Reply   
i´m owner of 2004 supra gravity game edition. the perfect pass is not working. the display works.
if i set the speed on the display and star launching.... when the boat arrives to the "desire speed" the engine doesn´t hold it.
any help, ?? thank you
Old     (t0nyv831)      Join Date: Jun 2008       10-29-2009, 11:23 PM Reply   
I'm not too familiar with Supra but I have PP on my Sanger V215. I would do a throttle cable test by doing the following:

Open your engine compartment and find you servo motor by locating your throttle cabe first. Once you've located the cable, follow it back to the servo motor. The servo is typically mounted on a bracket which is secured on one of your intake water hoses on your engine.

Once you've located it, there is a black knob you can turn counter-clockwise (I believe)until you let off all the slack in the cable. Turn the knob until all the slack is out of the cable.

Now, without turning the engine over, turn your ignition key until your aux electronics kick on, but not your engine (especially if it's out of water)

Once the key is on and your PP is on, the servo motor should turn on and wind up any excess slack. If you touch your servo motor at this point, it should feel warm which means it's doing work.

If it does not wind up the slack, then you've lost power to the servo motor or you've got a bad servo.

Hope this helps.
Old     (captain_542)      Join Date: Oct 2006       10-30-2009, 7:58 AM Reply   
i have this same problem. Everything on the dash works as it should and the PP beeps when i reach the set speed as to say it will hold but nothing happens. My boat is winterized but I will check the servo motor as well.

How hard is it to replace a servo motor? can i purchase one by itself? where?
Old     (islander033)      Join Date: May 2008       10-30-2009, 8:14 AM Reply   
"How hard is it to replace a servo motor? can i purchase one by itself? where?"

It is easy to replace. I'm sure that you can order one from PP directly at this # 1-(902)-468-2150
Old     (jonblarc7)      Join Date: Jul 2006       10-30-2009, 8:22 AM Reply   
Call perfect pass, those guy are really good guys and very helpful. They have help me on more than one boat and fixed the problem every time.
Old     (hugo_salcedo)      Join Date: Mar 2007       10-30-2009, 10:39 AM Reply   
thank you guys... this helps
Old     (loudontn)      Join Date: Feb 2005       11-01-2009, 5:35 PM Reply   
I have an '05 Supra and I had to replace mine when I bought it this summer, it took about 10 minutes to replace. I had the exact same problem, mine wouldn't hold the right speed after replacing it but it would now HOLD a speed. I had to replace the paddle wheel, now it's golden. I don't know how I lived without it on my last boat.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 6:06 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2019 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us