Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > >> Boats, Accessories & Tow Vehicles Archive > Archive through May 29, 2009

Share 
Reply
 
Thread Tools Display Modes
Old    Randy (dudeman)      Join Date: Mar 2005       04-26-2009, 6:49 PM Reply   
Never smelled it before. In a cove with my wife on Friday for 2 hours and bad fuel smell. Tried to start the boat and nothing. Had to pull the fuel filter and blow thru it. For some reason it had a vapor lock. No fuel leaking and nothing in the bilge. Today, same smell, 3/4 of a tank and it read empty within 2 hours on the meter. Probably 2500lbs of ballast. Same thing we always run. Really weird. Anyone have any clue on what this could be. I'm pretty mechanically savvy and so was my crew, but this is kind of baffling.
Old    Claudiu Barbura (claudiub)      Join Date: Apr 2008       04-27-2009, 1:45 AM Reply   
I had to replace my fuel tank last year, 05 Launch 21V. It was leaking.
Old    Randy (dudeman)      Join Date: Mar 2005       04-27-2009, 3:38 AM Reply   
Claudiu, what determined a leaking tank? That's the baffling thing with mine. No fuel in the bilge and no fuel going over board.
Old    Robert A (cocheese)      Join Date: Jul 2004       04-27-2009, 6:53 AM Reply   
Hey Randy. We met this weekend and you are the coolest people on the lake! We have the same problem this time of the year. I had numerous emails and phone calls to Indmar reps last year and the problem with ours is winter blend gas. Ours also vapor locked this weekend. When it does either wait it out for an hour or so or take a wet towel and place it on the fuel pump in the engine compartment. You can also dump a cup of water on it. All the dealers I have talked with said it is a known problem with the 21v and this is their solution. It clears up towards the end of spring when they switch to summer blend gas. Hit us up anytime you are out. You guys are welcome on our boat anytime.
Old    Randy (dudeman)      Join Date: Mar 2005       04-27-2009, 7:33 AM Reply   
Thanks Robert. Nice meeting you and your wife. I've had the vapor lock last summer because I was idling around without the blower on. Just not sure what the fuel smell is. Either the fuel gauge wasn't reading right or we burned a lot of fuel faster than I ever had before. Just happened to look down at the gauge. Think we just made it back.
Old    Robert A (cocheese)      Join Date: Jul 2004       04-27-2009, 8:30 AM Reply   
Ours only vapor locks when we sit for a long period of time after riding. We have tried opening the hatch and running the blower when we stop and eat, but every time we return to the boat and it vapor locks. It only happens in the early spring and late fall. No problems in the summer. Don't know what would make yours burn faster or smell other than bad gas maybe?
Old    Claudiu Barbura (claudiub)      Join Date: Apr 2008       04-27-2009, 11:29 AM Reply   
I just happened to have a "bad tank", according to the dealer. I had gas in the bilge .. .thanks God nothing happened...

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 2:06 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2016 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us