Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > Wakeboarding Discussion

Share 
Reply
 
Thread Tools Display Modes
Old     (mike2001)      Join Date: Feb 2008       08-27-2015, 9:25 PM Reply   
I have a Slingshot Choice with older Liquid Force Watsons mounted to it. Love the board and the Watsons are some of the most comfortable bindings I've ever used. The problem is, I mount the bindings pretty much in the middle of the fast track for both feet. However, no matter how much I tighten down the screws of the SS mounting hardware, the bindings always push out to the widest position within a couple minutes of riding.

Anyone else have this issue? Am I just not tightening the screws enough? I emailed Slingshot and they suggested I put a stint in the fast track. If anyone else has done this, what have you used as a stint? Thanks.
Old     (Kane)      Join Date: Mar 2010       08-28-2015, 1:28 AM Reply   
Either find shorter screws / grind the current ones down or (what I did) put an extra washer on your screw.
Old     (boardjnky4)      Join Date: Dec 2011       08-28-2015, 6:17 AM Reply   
You can try shorter screws to get them tighter. They are 1/4-20 screws. Easy to find at any hardware store.

As far as stinting the bindings, very common to do. A lot of people use spare screw inserts. Just need to go to the hardware store and use your imagination.
Old     (bruh)      Join Date: Jan 2015       08-30-2015, 7:03 PM Reply   
this happened to me with ronix bindings on my slingshot. only happens every once in a while and I just tighten them again
Old     (simplej)      Join Date: Sep 2011       09-02-2015, 4:47 AM Reply   
Put the stint in. It's the only way.

Fast track is the sole reason I am not on a slingshot this season
Old     (LYNRDSKYNRD)      Join Date: Sep 2012       09-02-2015, 1:03 PM Reply   
My son was having the same issue with his Slingshot RADS. A Slingshot team rider saw his set up and gave him different hardware than what came with his bindings and they haven't moved since. The new hardware had a small thin rubber washer that goes between the bindings and the board. I think that is what is holding them in place so well now.
Old     (simplej)      Join Date: Sep 2011       09-02-2015, 1:35 PM Reply   
Mine had that and still had issues.


Those ones hold slightly better because the screw goes down into the bottom of the track though.

The really need to put teeth in them.
Old     (Dustfarter)      Join Date: Jun 2010       09-07-2015, 9:49 PM Reply   
Fast track is one of the main reasons I moved away from SS this season.

I had the same issues. The easy fix is go to a asian restaurant and get some bamboo chopsticks. Not the crappy wood ones. Cut them to the correct length for your stance and lay them flat in the channel between your binding post and the end of the track. It works like a charm and there will be no more slippage. The bamboo will flex with your board nicely.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 7:57 PM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2019 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us